brightness keys not working on macbook 3.1

Bug #163725 reported by sidgalt on 2007-11-19
12
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
hal (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Ubuntu 7.10 Gutsy with kernel 2.6.22-14-generic, both i386 and amd64 on my macbook 3.1. The brightness controls are not working. I have tried with/without fn key+f1, <ctrl>+f1, fn key + <ctrl> + f1.
I also installed the apple keyboard patch http://launchpadlibrarian.net/10334998/hid-add-new-apple-keyboard.patch but although the patch enabled the fn key, the brightness controls still don't work. I also tried
installing pommed v1.11 but even that has no effect. I tried with fn=1 and fn=2 (in pommed.conf)

My macbook has Intel GMA x3100 for processing graphics while pommed.conf has only gma950 in it.

PS - On the bootup of my newly compiled kernel, it says

i8042.c: No controller found

I compiled the kernel by getting the kernel source through - apt-get linux-source,
installed the mactel updates and the keyboard and touchpad patches. I also changed the
processor type to Core 2/New Xeon
The touchpad patch seems to be working fine.
Keyboard layout is Macbook/Macbook Pro

Chris Irwin (chrisirwin) wrote :

"/usr/share/hal/fdi/policy/10osvendor/10-macbook-backlight.fdi" needs to be updated to recognize the keys. Patch attached.

This does not actually adjust the brightness, however. That still needs to be fixed.

Chris Irwin (chrisirwin) wrote :

Just an update to note that xbacklight can correctly change the brightness..

Chris Irwin (chrisirwin) wrote :

pommed from svn can correctly change the screen brightness

Robert Nasiadek (robzon) wrote :

This bug still exists in Hardy Alpha 6.

Robert Nasiadek (robzon) wrote :

And Hardy Beta.

Adrián (adrianbn) wrote :

Its same problem in macbook4.1 with hardy beta

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in hal.

Changed in mactel-support:
status: New → Invalid
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, this bug is a duplicate of bug 129869, which incidentally was fixed in hal on March 21st (after beta), and is being marked as such. Feel free to submit any future bugs you may find.

Changed in hal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers