Brightness only works at certain levels with g-p-m due to invalid levels

Bug #162725 reported by Matthew Dutton on 2007-11-14
8
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: hal

On a Gateway MP8708, MP8709 and other non-Gateways, HAL reports laptop_panel.num_levels=101 but /proc/acpi/video/VGA/LCD/brightness is:
    levels: 100 37 12 25 37 50 62 75 87 100
    current: 0

gnome-power-manager (and probably other applications) assumes that num_levels means levels [0,num_levels) are valid. This is not the case for some backlights.

When an application uses HAL to set the brightness to an illegal value, /sys/class/backlight/... does not complain but instead sets the brightness to 0.

Since g-p-m uses 5% increments, the issue manifests as only brightnesses 0%, 25%, 50%, 75% and 100% working, at least for the complaints I've seen. Users have to press the brightness keys several times to to make it through all the dark settings to a working one.

See the g-p-m bug https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/121833 for more information.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in hal:
status: New → Incomplete
Matthew Dutton (matthewrdutton) wrote :

No.

(As of 8.04 I believe ) There are no more "dark zones" that have to be cycled through

There are still a couple of issues but I think they fall under a different bug.

Thanks for the follow up. I believe the fix for the referenced bug fixed this.

Matthew Dutton (matthewrdutton) wrote :

Who's responsible for updating the status? This bug should probably be "Fix released".

Ralph Janke (txwikinger) wrote :

Due to the response of the reporter, this issue will be closed. Thanks again for the help.

Changed in hal (Ubuntu):
importance: Undecided → Low
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers