[gutsy] laptop keyboard hangs after (un)plug ac adapter, regression

Bug #152633 reported by Konrad Materka on 2007-10-14
8
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

Hi, I found ugly regression in HAL package.
Firstly, I have laptop - Benq Joybook A53 - and when I (un)plug AC adapter it is recognized by monitor software, but keyboard and touchpad works VERY laggy. In fact, they stops to work beside some moments when I can move cursor a bit or write a letter. External USB mouse work flawlessly!
After some investigation I found, that installig hal package from feisty resolves the problem. Only hal package, all libhal1* stayed in newest version.
If you want, I can provide more information.
My versions:
wrong hal: 0.5.9-1-6ubuntu5
ok hal: 0.5.8.1-4ubuntu12

Installing other versions of acpi*, kernels doesn't change anything. Only Hal package is broken.

PS. If you give me a hind how to locate broken hal scrips, i'll do that :)

Konrad Materka (kmaterka) wrote :

I forgoten to mention, I uninstaled the hal-info package (dependency problem).
I can hal with this problem only by the end of next weekend (by 21.10.2007), because it's not my laptop :(

Antario (antario91) wrote :

This bug also occures in a Joybook A52. Can you give me further information about how to resolve it?

Changed in hal:
status: New → Incomplete
Konrad Materka (kmaterka) wrote :

I didn't resolved it, only workaround.
Try to install "hal" package from feisty. Remember, that hal from feisy have different dependencies (you have to remove hal-info package).

After installing old hal you wonn't be able to see battery state, until you plug and unplug again AC adapted. You can also (un)plug battery :)

I don't own this laptop any more, so I can't help you much. This is probably bug in acpi or/and in hal.

wan (wan-wan) wrote :

for first: sorry for english!

i have the same problem with my Benq Joybook A52E-906.

i go to the "/etc/default/acpi-support" than change line "ENABLE_LAPTOP_MODE=false" on ".*=true"

than i lost my tab in gnome-power-preferences, on the screenshot.

and it change my ?power? applet in next comment continue...

wan (wan-wan) wrote :

... it change my ?power? applet in next comment continue...

and output from acpi_listen has changed.

is anybody there who's work on this bug?

wan (wan-wan) wrote :

and i forget "hwdb-xml -a >....." output. in attachment

wan (wan-wan) wrote :

i hope...

If you can, please test the latest Hardy Alpha release which has hal version 0.5.10-5ubuntu8. Thanks.

Antario (antario91) wrote :

I tested the Alpha 4 a while ago and it worked very well :D No keyboard problem and I could use the acpi for my battery (in Gutsy I had to disable it in /etc/default/acpid). With Gutsy I have a black screen during boot (if I get an error massage for ex. I can't see it so I have to restart until the login screen appears), this is solved too. Very very Good Work, guys, Thank You :D

i test it on new ubuntu 8.04 beta6 live

and it works good but with some unperfection, when the battery goes down,
notebook maybe use auto shutdown or auto suspend. but it only hard fall down
power.

suspend works good
close display plays gong and turn off it

when i'll trie to send more about my Benq Joybook A52E-906

On Tue, Mar 4, 2008 at 8:24 PM, Antario <email address hidden> wrote:

> I tested the Alpha 4 a while ago and it worked very well :D No keyboard
> problem and I could use the acpi for my battery (in Gutsy I had to
> disable it in /etc/default/acpid). With Gutsy I have a black screen
> during boot (if I get an error massage for ex. I can't see it so I have
> to restart until the login screen appears), this is solved too. Very
> very Good Work, guys, Thank You :D
>
> --
> [gutsy] laptop keyboard hangs after (un)plug ac adapter, regression
> https://bugs.launchpad.net/bugs/152633
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Antario (antario91) wrote :

Yes... an auto power off or suspend would be a good idea...

Magnus S (magnuss) wrote :

Hi,
this bug report looks abandoned and is getting old, so i'm closing it now. If this issue is still affecting you, please reopen or submit a new report.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in hal:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers