HAL Crashes on first login

Bug #152010 reported by Zee Alexander on 2007-10-12
2
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

I've just installed the Gutsy RC release.

Everything worked fine . . . at first.

Now, every time I boot up, when I first log in to gnome, I get a message like:
"failed to initialize HAL", or something similar to that.

Now, when I open a terminal and perform:
sudo /etc/init.d/hal stop
sudo /etc/init.d/hal start

it works just fine.

However, I have to do this on EVERY boot.

JV (ziri01) wrote :

I have had also this problem after upgrade to gutsy. I thought that HAL uses DBUS subsystem and this dependency could cause problems.

Command runlevel told me that I am in runlevel 2. So I checked my /etc/rc2.d directory: there was a link called S12hal, but S50dbus! After I renamed the latter to S10dbus, the problem was solved.

Stéphane Loeuillet (leroutier) wrote :

Could you check this bug too :
https://bugs.edge.launchpad.net/ubuntu/+source/hal/+bug/149881

And see if it is not related ?

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in hal:
status: New → Incomplete

@ Daniel T Chen:
I got it today in Intrepid in VirtualBox (not OSE), all running in Intrepid host.

Thank you for taking the time to report this bug and helping to make Ubuntu better. The version of Ubuntu your using is in End of Life status. More information may be found at: https://wiki.ubuntu.com/Releases As well, the issue that you reported should be reproducible with the live environment of the Desktop CD development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Please repost a detailed error report and update the bug status. Thanks again and we appreciate your help.

Launchpad Janitor (janitor) wrote :

[Expired for hal (Ubuntu) because there has been no activity for 60 days.]

Changed in hal (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers