Fn Keys No Longer Control Brightness (Toshiba P200)

Bug #141623 reported by Trip Ericson on 2007-09-21
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

It seems like ever since a system update earlier this week (one that updated a number of things, but acpi packages stuck out), my Fn keys no longer control the brightness.

Up until that update, Fn+F6 and Fn+F7 would decrease and increase the brightness, respectively. Now it can be controlled with the Power Manager, but not through the Fn keys. Again, this worked correctly until a recent update.

I have a Toshiba P200-ST2061 (Santa Rosa guts).

trip@trip-p200:~/workspace$ sudo dmidecode -s system-manufacturer
TOSHIBA
trip@trip-p200:~/workspace$ sudo dmidecode -s system-product-name
Satellite P200
trip@trip-p200:~/workspace$ sudo dmidecode -s system-version
PSPB3U-03E00Y

Fn+F6: 0xe0 0x4c 0xe0 0xcc
Fn+F7: 0xe0 0x54 0xe0 0xd4

Doing "sudo tail -f /var/log/acpid" shows:

[Fri Sep 21 18:47:18 2007] received event "video DD03 00000086 00000000"
[Fri Sep 21 18:47:18 2007] notifying client 10412[0:0]
[Fri Sep 21 18:47:18 2007] executing action "/etc/acpi/video_brightnessup.sh"
[Fri Sep 21 18:47:18 2007] BEGIN HANDLER MESSAGES
[Fri Sep 21 18:47:18 2007] END HANDLER MESSAGES
[Fri Sep 21 18:47:18 2007] action exited with status 0
[Fri Sep 21 18:47:18 2007] completed event "video DD03 00000086 00000000"
[Fri Sep 21 18:47:19 2007] received event "video DD03 00000087 00000000"
[Fri Sep 21 18:47:19 2007] notifying client 10412[0:0]
[Fri Sep 21 18:47:19 2007] executing action "/etc/acpi/video_brightnessdown.sh"
[Fri Sep 21 18:47:19 2007] BEGIN HANDLER MESSAGES
[Fri Sep 21 18:47:19 2007] END HANDLER MESSAGES
[Fri Sep 21 18:47:19 2007] action exited with status 0
[Fri Sep 21 18:47:19 2007] completed event "video DD03 00000087 00000000"

It makes me think that the problem is with acpi and not with hotkeys, but I'm leaving it undesignated since I'm not an expert.

Any other information can be provided upon request.

Matthew Garrett (mjg59) wrote :

Are you using KDE?

Trip Ericson (rovfan) wrote :

Yes. Also, I don't know when it started, but now my brightness does not change with Power Manager either. It worked right after bootup a few hours ago, but not now.

Trip Ericson (rovfan) wrote :

Yes. Also, I don't know when it started, but now my brightness does not change with Power Manager either. It worked right after bootup a few hours ago, but not now.

I also need to add that I'm running the Gutsy alpha with all the latest updates.

TQ (tjgq) wrote :

I'm running gutsy on a Toshiba A200 1GB and this happened to me also after this morning's upgrade to the latest packages (the upgrade brought in kernel 2.6.22-12, but the problem might be in another package).

Fn+F6 and Fn+F7 (decrease/increase brightness) don't work anymore, even though I can set the brightness via the power manager systray applet (I'm running Kubuntu).

Trip Ericson (rovfan) wrote :

It started for me before 2.6.22-12 was installed.

Within a few hours, I could not control brightness via the power manager systray applet either (I noticed it when I unplugged the system and the brightness did not change).

urho (vonturha) wrote :

i have Toshiba A200-S17 and brightness down (FN+F6) works fine but brightness up (FN+F7) does not, when pressing it indicator goes up for one step and pressing another time it goes down for one step! brightness systray applet don't work either. Actually FN+6 is the only special key that works for me in my laptop

Trip Ericson (rovfan) wrote :

I think this bug is rather important, seeing as it is not possible to control the brightness from within Kubuntu at all, despite the fact that this worked fine up until the last update to acpi. I really wish that somebody who is capable of fixing would look at it...

Trip Ericson (rovfan) wrote :

An update to KDE's power manager now, once again, seems to be allowing me to control the brightness from the power manager in the system tray. The keys still do not work.

Was something changed in the ACPI controller that doesn't allow for the Fn+F6 and Fn+F7 to work anymore?

Trip Ericson (rovfan) wrote :

I'd like to note that somewhere along the way, the brightness broke again, and one again cannot be controlled. However, booting off of a live CD, I note that I am able to at least partially control it. I'm going to wait until the first Hardy Alpha comes along with a new kernel and see if that helps my issue. If it does, I'm happy, and if not, then I'll attempt to provide any more details, if needed.

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in hal:
assignee: nobody → andreas-moog
status: New → Incomplete
Trip Ericson (rovfan) wrote :

Yeah, I reloaded with 8.04 back in April and that corrected my issue. Being that I'm now using the Intrepid alpha, I have completely different issues, but those are being addressed elsewhere.

Andreas Moog (ampelbein) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in hal:
assignee: andreas-moog → nobody
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers