wrong # of brightness levels reported by hal -> kde-guidance-powermanager uses 100% CPU

Bug #138956 reported by Klaus S. Madsen on 2007-09-11
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kde-guidance-powermanager

When right-clicking the battery icon, and choosing restore, the window comes up, half drawn and the guidance-power-manager process starts using 100% CPU time. Then after a while (10-20 seconds), the "Battery Powered" brightness slider appears. After another 10-20 seconds, the "Mains powered" brightness slider appears. In both cases there are no marks on the slider, and they don't work.

I'm running Gutsy with kde-guidance-powermanager version 0.8.0svn20070727-0ubuntu6, on an IBM T61p, using the vesa driver for X.

It turns out that this is caused by hal reporting that there are 134648572 brightness levels. So this is most likely a bug in hal?

Luka Renko (lure) wrote :

Yes, it is either bug in HAL or lower (kernel, BIOS...). Changing package to HAL.

Luka Renko (lure) wrote :

Similar problems reported on another IBM laptop in bug 139205

My problem is exactly the opposite of bug 139205. Once the window have been drawn, I have two solid black lines above and below the brightness slider (from the tick marks).

Luka Renko (lure) wrote :

I just wanted to indicate that the root cause for both bugs may be the same: HAL not reporting brightness levels correctly anymore (only one level or excessive number of levels).

Daniel T Chen (crimsun) wrote :

Is this symptom reproducible in 8.10 RC or later?

Changed in hal:
status: New → Incomplete

No. Actually it isn't even reproducible in 8.04 where there are the correct number of brightness levels.

So I'll close this bug. Sorry for not following up on it when it started working for me.

Changed in hal:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers