User-friendly selection of suspend method

Bug #136737 reported by David Jaša on 2007-09-02
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Wishlist
Unassigned
pm-utils (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: hal

If you install uswsusp or hibernate, you've got to change/modify configuration files in /usr/lib/hal/scripts/linux by hand so that desired method of suspend is used after pressing of ACPI buttons or choosing Suspend or Hibernate from logout menu. This choice should be available in more straightforward way, probably by debconf or by some new GUI tool.

Chris Jones (cmsj) wrote :

are things like uswsusp/tuxonice even remotely supported? AIUI they have been rejected from the upstream kernel and the existing kernel suspend/hibernate paths are going to be separated and improved.

On Fri, 2008-08-01 at 10:09 +0000, Chris Jones wrote:
> are things like uswsusp/tuxonice even remotely supported? AIUI they have
> been rejected from the upstream kernel and the existing kernel
> suspend/hibernate paths are going to be separated and improved.

uswsusp is enirely supported in the main kernel -- Pavel and Rafael are
the suspend/resume subsystem maintainers, and uswsusp is their baby.

--
Victor Lowther
Ubuntu Certified Professional

Daniel T Chen (crimsun) on 2008-10-19
Changed in pm-utils:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in hal:
importance: Undecided → Wishlist
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

While uswsusp and the kernel method of pm-utils suspend is supported in
the kernel, Ubuntu's devs don't believe in allowing users to use
uswsusp. See Bug #267141 and you'll see that the only reason they have
uswsusp support is because upstream pm-utils does. And even then it's
broken because s2ram is missing (Bug #134238).

Basically, if you want uswsusp, you're going to hack on your own system.
Ubuntu devs won't hear of any support for uswsusp. Only the kernel
method.
--
Chow Loong Jin

Chow Loong Jin (hyperair) wrote :

Okay, I'm not sure exactly how user-friendly you'd want it, but right
now we've got a file in /etc/pm/config.d/00sleep_module which allows you
to select your sleep module. uswsusp, kernel, and tuxonice are
supported. tuxonice will of course require a patch in the kernel, but
that's a different matter entirely.

For now I'll mark this as fix released, feel free to reopen if it's not
user-friendly enough.

  affects ubuntu/pm-utils
    status fixreleased

  affects ubuntu/hal
    status invalid
--
Chow Loong Jin

Changed in hal:
status: Confirmed → Invalid
Changed in pm-utils:
status: Confirmed → Fix Released
David Jaša (dejv) wrote :

This sounds much more friendly than modifying hal scripts by hand. At least for me. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers