System restart when inserting a cdrom

Bug #126027 reported by Guti on 2007-07-14
2
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

I don't really know how to approach this bug, everytime I try to access my cdrom (DVD RW) the system reboots.
I encountered this problem when inserting a blank cd and tried to burn to it using k3b, also when I inserted a normal cd (The system restarted just after hald detected it and tried to mount it).

I looked in the logs (syslog / debug) and the last message before the restart is something like:
Jul 14 15:29:18 guti-desktop kernel: [ 266.705149] cdrom: This disc doesn't have any tracks I recognize!
Jul 14 15:29:18 guti-desktop NetworkManager: <debug> [1184416158.460927] nm_hal_device_added(): New device added (
hal udi is '/org/freedesktop/Hal/devices/volume_empty_cd_r').

I'm running gutsy using kernel 2.6.22-8-generic.

I`m experiencing a similar Problem at the moment, on a up-to-date Kubuntu Hardy Heron with KDE 3.5.9

I insert a empty CD-R, or DVD+R in my CD-ROM drive, after a while the Window from kded appears and asks me what to to, if I click on "burn data CD" (or something similar in german it is "Daten-DVD mit k3b erstellen") I see that K3B starts (because my mousecursor is bouncing), then I get a blank screen, and the kdm Login-Screen appears. I haven`t experienced restarts yet, just logouts, or kdm restarts.

Also this doesn`t happen every time, just lets say seven to eight out of ten times.
This is the first time this happens, I didn`t had any problems in Gutsy.

dmesg says:
[ 499.206263] end_request: I/O error, dev sr0, sector 0
[ 499.208097] end_request: I/O error, dev sr0, sector 4
[ 562.587580] printk: 56 messages suppressed.
[ 562.587593] software-proper[10955]: segfault at 0065008a eip b6bb06e6 esp bfc730c0 error 4
[ 612.307850] cdrom: This disc doesn't have any tracks I recognize!
[ 650.408535] cdrom: This disc doesn't have any tracks I recognize!
[ 713.717916] cdrom: This disc doesn't have any tracks I recognize!

I attached the whole dmesg-messages, created via dmesg > dmesg.txt

Changed in hal:
status: New → Confirmed
dino99 (9d9) wrote :
Changed in hal (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments