Missing hal-luks-setup scripts in hal package (Edgy)

Bug #118644 reported by TJ on 2007-06-04
2
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

On Edgy 32-bit (not sure about 64-bit) the hal package (0.5.7.1-0ubuntu17) has scripts missing from /usr/lib/hal/scripts.

In trying to get LUKS (dm-crypt external USB hard drives) to mount, the system wasn't auto-mounting as expected. After comparing the package list for Feisty's hal 0.5.8.1-4ubuntu12 it seems that Edgy's hal 0.5.7.1-0ubuntu1 is missing at least these files:

/usr/lib/hal/scripts/hal-luks-remove
/usr/lib/hal/scripts/hal-luks-setup
/usr/lib/hal/scripts/hal-luks-teardown

/usr/lib/hal/scripts/linux/hal-luks-remove-linux
/usr/lib/hal/scripts/linux/hal-luks-setup-linux
/usr/lib/hal/scripts/linux/hal-luks-teardown-linux

Both Edgy and Feisty packages have the file

/usr/share/hal/fdi/policy/10osvendor/15-storage-luks.fdi

which defines the scripts to call; in particular:

 <append key="org.freedesktop.Hal.Device.Volume.Crypto.method_execpaths" type="strlist">hal-luks-setup</append>
 <append key="org.freedesktop.Hal.Device.Volume.Crypto.method_execpaths" type="strlist">hal-luks-teardown</append>

In Edgy these scripts are missing.

Martin Pitt (pitti) wrote :

Those scripts are present since Feisty.

Changed in hal:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers