Ubuntu

systemd-udevd[1440]: failed to execute '/lib/udev/socket:@/org/freedesktop/hal/udev_event' 'socket:@/org/freedesktop/hal/udev_event': No such file or directory

Reported by dino99 on 2013-05-22
172
This bug affects 39 people
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
High
Unassigned

Bug Description

dmesg logged errors

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: systemd-services 202-0ubuntu6
ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3
Uname: Linux 3.9.0-2-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.10.1-0ubuntu1
Architecture: i386
Date: Wed May 22 10:42:55 2013
MarkForUpload: True
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
Martin Pitt (pitti) wrote :

That's due to /lib/udev/rules.d/90-hal.rules, which uses a syntax which isn't supported any more.

hal itself has been deprecated many years ago, so this is most likely a "wontfix". We should really just drop it from the archive.

affects: systemd (Ubuntu) → hal (Ubuntu)
Changed in hal (Ubuntu):
importance: Undecided → High
Martin Pitt (pitti) wrote :

To fix this on your system, please just purge hal.

dino99 (9d9) wrote :

Thanks for the info

have purged all the related "hal" packages, except libhal1 which is still used

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hal (Ubuntu):
status: New → Confirmed
martin suc (martin-suc) wrote :

this error appeared as welll for multipath:
[ 35.698746] systemd-udevd[8149]: failed to execute '/lib/udev/socket:/org/kernel/dm/multipath_event' 'socket:/org/kernel/dm/multipath_event': No such file or directory.

martin suc (martin-suc) wrote :

and:
systemd-udevd[665]: failed to execute '/lib/udev/usb-db' 'usb-db /devices/pci0000:00/0000:00:12.2/usb1': No such file or directory

dino99 (9d9) wrote :

as per #6 & #7 above, re-add systemd as affected, as it appear related to something else than "hal" in that case.

Is it possible to keep hal working for a little longer? It's required by flash to play some videos:

http://helpx.adobe.com/x-productkb/multi/flash-player-11-problems-playing.html

Looking around a bit, archlinux look like they have a patch to pull the events directly from udev. It's hal-libudev-events.patch in here:

https://aur.archlinux.org/packages/ha/hal/hal.tar.gz

I pulled some patches from archlinux and droped the installation of /lib/udev/rules.d/90-hal.rules

https://launchpad.net/~mjblenner/+archive/ppa-hal

It works for me in the only purpose I care about (some DRM'ed flash video).

(it also fixes this bug)

I think we should either provide fixed hal on archive (mostly for flash issue) and uninstall this on upgrade procedure...

dino99 (9d9) wrote :

hal removed now

Changed in hal (Ubuntu):
status: Confirmed → Fix Released
no longer affects: systemd
Jaison Daniel (jjaison-daniel) wrote :

The issue still there in my system. My system is upto date. I will run the updater daily.
version: Ubunut 13.10
last update runs: 29 October 2013.

I saw this issue after I upgrade from 13.04 to 13.10.
Please let me know if you need any more information.

Jaison Daniel (jjaison-daniel) wrote :

Arch: 64 bit

bash $uname -a
Linux jjux64 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
bash $
bash $id
uid=1000(jj) gid=1000(jj) groups=1000(jj),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),29(audio),30(dip),44(video),46(plugdev),104(fuse),109(lpadmin),119(pulse),120(pulse-access),124(sambashare),130(vboxusers),131(nm-openconnect)
bash $
bash $lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy
bash $

I had the nividia binary driver and it has things like "HAL autodetects the screen" in X11/xorg.conf. My screen went to 640x480 and I tried to install the nouveau drivers. I also tried to disable KMS with 'nomodset'. I did purge hal as instructed, but every time I reboot, I get a 640x480 X11 screen. It is hard to find a solution on the Internet with this screen resolution. Is this related or do I have a completely different issue?

First run
$ modprobe nvidiafb

$ modprobe nouveau # gives
Module '=off' not found. ... or something like that.

I have manually installed all the modules looking at '/lib/modules/`uname -r`/modules.dep

$ grep nouveau /lib/modules/`uname -r`/modules.dep
kernel/drivers/gpu/drm/nouveau/nouveau.ko: kernel/drivers/platform/x86/mxm-wmi.ko kernel/drivers/platform/x86/wmi.ko kernel/drivers/acpi/video.ko kernel/drivers/gpu/drm/ttm/ttm.ko kernel/drivers/gpu/drm/drm_kms_helper.ko kernel/drivers/gpu/drm/drm.ko kernel/drivers/i2c/algos/i2c-algo-bit.ko

Each individual line works with 'modprobe', but not nvidia. Then I have to run 'sudo /etc/init.d/lightdm restart' and then I have the nouveau drivers recognized. Now, you can look at '/var/log/Xorg.0.log' and see why your modes are rejected. Run through this link to manually add resolutions.

 http://www.ubuntugeek.com/how-change-display-resolution-settings-using-xrandr.html

Lesson: Don't change to 'nouveau' from the 'nvidia binaries' if you hit this bug. If you did, then maybe the above helps. My display is still flakey; no doubt because of the modeline I have to cook up now.

Each individual line works with 'modprobe', but not <strike>nvidia</strike> nouveau.

$ sudo modprobe nouveau
[sudo] password for bpringlemeir:
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='off'
ERROR: could not insert 'off': Function not implemented

$ sudo strace modprobe nouveau
...
$ sudo mv /etc/modprobe.conf/nvidia-current_hybrid.conf ~

and reboot. The 'nvidia-binary' package doesn't clean up. Now, does the nvidia-binary need the 'hal' package to set resolutions? Or did I proceed on an alternate path to pain.

R.M. Hildigerr V. (moonsdad) wrote :

In order to continue using Thoggen, upon updating to Saucy, I installed the old package and it's hal dependency. Then, I began having this issue as well. Rather than remove it as a "fix", I simply commented out the offending line in /lib/udev/rules.d/90-hal.rules

Would it be better to use Michael Blennerhassett's PPA version? I'm not sure what the included arch patches are for.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers