Mounting floppy in an external usb floppy drive in Konqueror causes this error "Method "Mount" with signature "ssas" on interface "org.freedesktop.Hal.Device.Volume"

Bug #112468 reported by Highway on 2007-05-04
10
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Konqueror on Kubuntu running Kde3.5.5 on a Dell Latitude D600
When i plug in my external usb floppy drive, and insert a disk, a box appears offering the choice of opening in a new window, or cancel.

I choose to open in a window, but nothing happens. When i open konqueror manually, and go to Storage Media, the External Floppy Drive appears. When I click on it, I get the following error:

Method "Mount" with signature "ssas" on interface "org.freedesktop.Hal.Device.Volume" doesn't exist

Any advice welcome.

Dermot.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thank you for taking the time to report this bug and helping to make
Ubuntu better. You reported this bug a while ago and there hasn't been
any activity in it recently. We were wondering is this still an issue
for you? Can you try with latest Ubuntu release? Thanks in advance.

 status incomplete
 assignee <email address hidden>
 subscribe

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkit4YAACgkQ06FgkPZwicREigCdFbYHqrT38W73o41rKqSrnp86
pioAn33jXJ9RiDeK8jRLiSV1otMQ2kha
=yqtp
-----END PGP SIGNATURE-----

Changed in hal:
assignee: nobody → andreas-moog
status: New → Incomplete
Andreas Moog (ampelbein) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in hal:
assignee: andreas-moog → nobody
status: Incomplete → Invalid
Jacob Deker (jacob-deker) wrote :

Hi!
I am having the same issue today with my Kubuntu Hardy (still KDE3) installation on an ACER TravelMate 290. Actually, I was trying out encrypting one USB key with LUKS:

luksformat -t vfat /dev/sdb1
> YES
> /password/ (3 times)

Unplug the USB key, re-plug it again, and then comes the dialog asking for the action to take (Decrypt vs. not doing anything), I chose Decrypt, entered the right password (of this I am sure...), and then nothing. Trying to mount the /dev/mapper/luks_xxxx device manually works fine, but it does not work using the right-click/Mount scenario on the USB key's icon on the desktop. The message that pops up is exactly the same as first mentionned in this bug:

Method "Mount" with signature "ssas" on interface "org.freedesktop.Hal.Device.Volume" doesn't exist

To be honest, here is what I also tried:

- when, after having gotten this message, I use "right-click/Safely Remove", unplug, and then plug again, it almost never works
- but when I skip the "right-click/Safely Remove" part, it works more often than not (i.e. directly unplug and re-plug)

If that helps...
I will change the status of this entry to "New" again, as requested.

Changed in hal:
status: Invalid → New
Jacob Deker (jacob-deker) wrote :

As an additional help, here are the three outputs of the lshal command run
1. when the device was not plugged in
2. when the device was plugged in, but KDE refused to mount it
3. when the device was plugged in and KDE was ready to mount it

You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in hal (Ubuntu):
status: New → Incomplete

Actually I do not have any latest Ubuntu release with KDE installed any more
(got fed up with it at the "intrepid" stage); I only have a gnome
installation on Jaunty right now.

Nevertheless, it indeed seems to work fine now, for all that I can tell.

Hope that helps.

On Tue, May 19, 2009 at 00:53, Teej <email address hidden> wrote:

> You reported this bug a while ago and there hasn't been any activity in
> it recently. We were wondering if this is still an issue for you. Can
> you try with the latest Ubuntu release? Thanks in advance.
>
> ** Changed in: hal (Ubuntu)
> Status: New => Incomplete
>
> --
> Mounting floppy in an external usb floppy drive in Konqueror causes this
> error "Method "Mount" with signature "ssas" on interface
> "org.freedesktop.Hal.Device.Volume"
> https://bugs.launchpad.net/bugs/112468
> You received this bug notification because you are a direct subscriber
> of the bug.
>

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in hal (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments