Automounting firewire disk devices doesn't work

Bug #110247 reported by Andreas Ntaflos on 2007-04-26
6
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

I suspect this is a HAL issue but I haven't found a similar bug filed.

Using:
Kubuntu 7.04
hal-0.5.8.1-4ubuntu12
Third generation iPod (FAT-formatted and connected via firewire).

Problem description:
Plugging in the iPod doesn't draw any reaction from KDE. The device nodes get created (/dev/sdb, /dev/sdb1 and /dev/sdb2) and I can manually mount the iPod fine, but neither media:/ nor "dcop kded mediamanager fullList" as suggested by Amarok show any iPod-related devices.

USB devices like a USB key seem to work fine, automounting-wise.

I'm not sure what further information I could provide or how to debug this in a better way. If there's anything else I could post please let me know.

Wousser (wousser) wrote :

Thanks for you bug report.
To provide further information please take a look at:
https://wiki.ubuntu.com/DebuggingRemovableDevices
Thanks

Changed in hal:
status: New → Incomplete
Christophe Fergeau (teuf-gnome) wrote :

I'm seeing the same issue on gutsy with a 4g iPod plugged through firewire. When I plug in my ipod, dmesg reports the 2 partitions that are on the iPod, but it doesn't get mounted automatically. However, when I restart hal (/etc/init.d/hal restart), the iPod gets mounted. If I eject the iPod and replug it, it doesn't get automounted.
Looking in hal-device-manager, I notice that when the iPod is automounted (that is, after a hal restart with the iPod plugged), I have additionnal nodes containing disk partitions.... See the attached lshal logs.

Christophe Fergeau (teuf-gnome) wrote :

The same setup (ipod 4g plugged through firewire) was working fine when I was using feisty, and it never worked since I upgraded to gutsy (2 weeks ago iirc)

Christophe Fergeau (teuf-gnome) wrote :

Oh, sorry for spamming this bug report, I attached lshal output since they seemed relevant, let me know if you want additional information.

Launchpad Janitor (janitor) wrote :

[Expired for hal (Ubuntu) because there has been no activity for 60 days.]

Christophe Fergeau (teuf-gnome) wrote :

I provided some additional details last week, reopening.

Changed in hal:
status: Invalid → New
Andrew (andrewlevine) wrote :

I've been having the same problem lately with my 4g ipod. Restarting hal fixes the problem.

Here is my gvm and udev debug output before I restart hal. Would be happy to help debug if anyone has questions for me.

Andrew (andrewlevine) wrote :

This might be fixed on hardy, at least the 1st time I plugged my ipod it worked :)

After more tests, I can confirm this now works flawlessly on ubuntu hardy.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This bug report is being closed due to your last comment regarding this
being fixed with an update. For future reference you can manage the
status of your own bugs by clicking on the current status in the yellow
line and then choosing a new status in the revealed drop down box. You
can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status
. Thank you again for taking the time to report this bug and helping to
make Ubuntu better. Feel free to submit any future bugs you may find.

 status invalid
 assignee nobody

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkit09EACgkQ06FgkPZwicQwyQCghebuptVNbpm/GQ4CLlaHYFN4
pnwAoM70RVSG3pr5MrVl18aQayDv0FFQ
=yMCe
-----END PGP SIGNATURE-----

Changed in hal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers