[feisty] default sync mount of external usb is *slow*, how to reverse?

Bug #104241 reported by reagle on 2007-04-07
8
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

I'm running feisty beta, and when I went to do my backups yesterday, I noticed it was painfully slow compared to edgy. Writes to an external usb2 drive with ehci_hcd are horribly slow.

Linux urd 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

FAST READ
urd:/home/reagle> time `cp /media/wd1200/test.mpg .; sync`

real 0m1.559s
user 0m0.000s
sys 0m0.224s

SLOW WRITE
urd:/home/reagle> time `cp test.mpg /media/wd1200/test.mpg; sync`

real 0m46.811s
user 0m0.012s
sys 0m0.428s

reagle (joseph.reagle) wrote :
Download full text (4.0 KiB)

Also a problem with 2.6.20-14-generic, here's the syslog

Apr 7 16:33:20 localhost kernel: [ 104.326766] usb 7-5.3: new high speed USB device using ehci_hcd and address 5
Apr 7 16:33:20 localhost kernel: [ 104.420426] usb 7-5.3: configuration #1 chosen from 1 choice
Apr 7 16:33:20 localhost NetworkManager: <debug info>^I[1175978000.953032] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_1058_200_0061410').
Apr 7 16:33:20 localhost kernel: [ 104.466817] usbcore: registered new interface driver libusual
Apr 7 16:33:20 localhost kernel: [ 104.473745] Initializing USB Mass Storage driver...
Apr 7 16:33:20 localhost kernel: [ 104.473814] scsi6 : SCSI emulation for USB Mass Storage devices
Apr 7 16:33:20 localhost kernel: [ 104.473865] usb-storage: device found at 5
Apr 7 16:33:20 localhost kernel: [ 104.473867] usb-storage: waiting for device to settle before scanning
Apr 7 16:33:20 localhost kernel: [ 104.473869] usbcore: registered new interface driver usb-storage
Apr 7 16:33:20 localhost kernel: [ 104.473872] USB Mass Storage support registered.
Apr 7 16:33:21 localhost NetworkManager: <debug info>^I[1175978001.008703] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_1058_200_0061410_if0').
Apr 7 16:33:21 localhost NetworkManager: <debug info>^I[1175978001.023660] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_1058_200_0061410_if0_scsi_host').
Apr 7 16:33:21 localhost NetworkManager: <debug info>^I[1175978001.037139] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_1058_200_0061410_usbraw').
Apr 7 16:33:25 localhost kernel: [ 109.471368] usb-storage: device scan complete
Apr 7 16:33:25 localhost kernel: [ 109.471738] scsi 6:0:0:0: Direct-Access WDC WD1200JB-32EVA0 15.0 PQ: 0 ANSI: 2
Apr 7 16:33:25 localhost kernel: [ 109.472850] SCSI device sdb: 234441648 512-byte hdwr sectors (120034 MB)
Apr 7 16:33:25 localhost kernel: [ 109.473723] sdb: Write Protect is off
Apr 7 16:33:25 localhost kernel: [ 109.473726] sdb: Mode Sense: 53 00 00 08
Apr 7 16:33:25 localhost kernel: [ 109.473729] sdb: assuming drive cache: write through
Apr 7 16:33:25 localhost kernel: [ 109.474729] SCSI device sdb: 234441648 512-byte hdwr sectors (120034 MB)
Apr 7 16:33:25 localhost kernel: [ 109.475597] sdb: Write Protect is off
Apr 7 16:33:25 localhost kernel: [ 109.475600] sdb: Mode Sense: 53 00 00 08
Apr 7 16:33:25 localhost kernel: [ 109.475602] sdb: assuming drive cache: write through
Apr 7 16:33:26 localhost kernel: [ 109.475605] sdb: sdb1
Apr 7 16:33:26 localhost kernel: [ 109.506639] sd 6:0:0:0: Attached scsi disk sdb
Apr 7 16:33:26 localhost kernel: [ 109.506680] sd 6:0:0:0: Attached scsi generic sg2 type 0
Apr 7 16:33:26 localhost NetworkManager: <debug info>^I[1175978006.064239] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_1058_200_0061410_if0_scsi_host_scsi_device_lun0').
Apr 7 16:33:26 localhost NetworkManager: <debug info>^I[1175978006.078222] nm_hal_device_added (): New de...

Read more...

reagle (joseph.reagle) wrote :

It is automatically mounted with sync:
/dev/sdb1 on /media/wd1200 type ext3 (rw,noexec,nosuid,nodev,sync,data=ordered)

Let's try to change that:

mount -t ext3 -o rw,noexec,nosuid,nodev,data=ordered,async /dev/sdb1 /mnt/test

Much better!

urd:/home/reagle> time `cp test.mpg /mnt/test/test.mpg; sync`

real 0m2.530s
user 0m0.008s
sys 0m0.184s

So the question now, is why is feisty automounting usb drives with sync whereas edgy didn't? How can I change this?

reagle (joseph.reagle) wrote :
reagle (joseph.reagle) on 2007-04-09
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. Now that the 7.10 Gutsy Gibbon release of Ubuntu is out, we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results. If the issue is still present in the new release, please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-source-2.6.20:
status: New → Incomplete

On Monday 22 October 2007, Leann Ogasawara wrote:
> [feisty] default sync mount of external usb is *slow*, how to reverse?
> https://bugs.launchpad.net/bugs/104241

Gutsy no longer mounts ext usb drive as sync, but is now using "flush" which
is much better.

Changed in linux-source-2.6.22:
status: New → Fix Released
Connor Imes (ckimes) wrote :

I am closing this bug on linux-source-2.6.20 (Ubuntu) since it is fixed in 2.6.22.

Does this problem still exist with hal in Hardy?

Thank you.

Changed in linux-source-2.6.20:
status: Incomplete → Invalid
Daniel T Chen (crimsun) on 2008-10-05
Changed in hal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers