USB flash drive recognized as a music player

Bug #90286 reported by Jon Tai on 2007-03-07
44
Affects Status Importance Assigned to Milestone
HAL
Won't Fix
Low
hal-info (Ubuntu)
Medium
Martin Pitt

Bug Description

In previous releases of Ubuntu, as well as in Feisty Herd 5, when I plug in an iPod, a "music player" icon appears on the desktop and Rhythmbox launches.

In previous releases of Ubuntu, but *not* in Feisty Herd 5, when I plug in a Corsair Flash Voyager USB pen drive, a "disk" icon appears on the desktop and I can browse my files.

In Feisty Herd 5, when I plug in the USB drive, a "music player" icon appears on the desktop and Rhythmbox launches, as if it were an iPod. I would expect this behavior if I had plugged in a music player, or even if I had plugged in a USB drive that contains music files, but Rhythmbox shouldn't launch when I plug in a USB drive that doesn't contain any music files.

ProblemType: Bug
Date: Tue Mar 6 18:59:43 2007
DistroRelease: Ubuntu 7.04
Uname: Linux ig88 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

Jon Tai (jontai) wrote :

In previous releases of Ubuntu, as well as in Feisty Herd 5, when I plug in an iPod, a "music player" icon appears on the desktop and Rhythmbox launches.

In previous releases of Ubuntu, but *not* in Feisty Herd 5, when I plug in a Corsair Flash Voyager USB pen drive, a "disk" icon appears on the desktop and I can browse my files.

In Feisty Herd 5, when I plug in the USB drive, a "music player" icon appears on the desktop and Rhythmbox launches, as if it were an iPod. I would expect this behavior if I had plugged in a music player, or even if I had plugged in a USB drive that contains music files, but Rhythmbox shouldn't launch when I plug in a USB drive that doesn't contain any music files.

ProblemType: Bug
Date: Tue Mar 6 18:59:43 2007
DistroRelease: Ubuntu 7.04
Uname: Linux ig88 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

Need the complete output of lshal (as attachment)

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output of 'lsusb' when the pen drive is connected? Thanks in advance.

Jon Tai (jontai) wrote :

jon@ig88:~$ lsusb
Bus 003 Device 002: ID 050d:0119 Belkin Components
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 002: ID 04b8:0110 Seiko Epson Corp. Perfection 1650
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 007: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 002 Device 001: ID 0000:0000

Created an attachment (id=9040)
lshal output after having attached the usb stick

Here is the output of lshal as requested.

This output was generated while the USB stick was still attached to a USB port.

Please let me know if you require further information.

Brian Murray (brian-murray) wrote :

Could you please also add the output of 'lshal' when the device is connected to your system as an attachment to your bug report? Thanks in advance.

Jon Tai (jontai) wrote :
Brian Murray (brian-murray) wrote :

Pertinent device from lshal:

udi = '/org/freedesktop/Hal/devices/storage_serial_Corsair_Flash_Voyager_AA90000000000061'
  info.addons = {'hald-addon-storage'} (string list)
  portable_audio_player.input_formats = {'audio/mpeg'} (string list)
  portable_audio_player.output_formats = {'audio/mpeg'} (string list)
  portable_audio_player.storage_device = '/org/freedesktop/Hal/devices/storage_serial_Corsair_Flash_Voyager_AA90000000000061' (string)
  portable_audio_player.access_method = 'storage' (string)
  portable_audio_player.type = 'generic' (string)
  block.storage_device = '/org/freedesktop/Hal/devices/storage_serial_Corsair_Flash_Voyager_AA90000000000061' (string)
  info.udi = '/org/freedesktop/Hal/devices/storage_serial_Corsair_Flash_Voyager_AA90000000000061' (string)
  storage.partitioning_scheme = 'mbr' (string)
  storage.removable.media_size = 129499136 (0x7b80000) (uint64)
  storage.requires_eject = false (bool)
  storage.hotpluggable = true (bool)
  info.capabilities = {'storage', 'block', 'portable_audio_player'} (string list)
  info.category = 'portable_audio_player' (string)
  info.product = 'Flash Voyager' (string)
  info.vendor = 'Corsair' (string)
  storage.size = 0 (0x0) (uint64)
  storage.removable = true (bool)
  storage.removable.media_available = true (bool)
  storage.physical_device = '/org/freedesktop/Hal/devices/usb_device_90c_1000_AA90000000000061_if0' (string)
  storage.lun = 0 (0x0) (int)
  storage.firmware_version = '1100' (string)
  storage.serial = 'Corsair_Flash_Voyager_AA90000000000061' (string)
  storage.vendor = 'Corsair' (string)
  storage.model = 'Flash Voyager' (string)
  storage.drive_type = 'disk' (string)
  storage.automount_enabled_hint = true (bool)
  storage.media_check_enabled = true (bool)
  storage.no_partitions_hint = false (bool)
  storage.bus = 'usb' (string)
  block.is_volume = false (bool)
  block.minor = 16 (0x10) (int)
  block.major = 8 (0x8) (int)
  block.device = '/dev/sdb' (string)
  linux.hotplug_type = 3 (0x3) (int)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_90c_1000_AA90000000000061_if0_scsi_host_scsi_device_lun0' (string)
  linux.sysfs_path_device = '/sys/block/sdb' (string)
  linux.sysfs_path = '/sys/block/sdb' (string)

Victor Osadci (victor-os) wrote :

The same happens for a LG flash drive:

Bus 005 Device 007: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 005 Device 002: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 005: ID 046d:c00e Logitech, Inc. M-BJ69 Optical Wheel Mouse
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Daniel Derozier (dcubed20) wrote :

I'd like to confirm this bug on my machine too (Feisty beta).

Here's my lsusb:
Bus 003 Device 004: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

and my lshal is attached.

Martin Pitt (pitti) wrote :

Ah, got it. Someone recently submitted an FDI rule for the 'Feiya Technology Corp Memory Bar' which is capable of music playback, but has the very same USB vendor/product ID than your flash drives. I am just going to revert that FDI.

Changed in hal:
assignee: nobody → pitti
importance: Undecided → Medium
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in hal:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 hal (0.5.8.1-4ubuntu11) feisty; urgency=low
 .
   * 30-mp3-player-fdi.patch: Remove "Feiya Technology Corp Memory Bar" again,
     since other Flash drives use the very same controller, but are not capable
     of music playback. (LP: #90286)
   * Remove debian/patches/33-prefer-pmi-over-powersave.patch, so that
     installing powersave actually makes hal use it. The patch is not necessary
     any more, since kpowersave does not depend on powersaved any more, so this
     does not reopen #61920. (LP: #90425)
   * Add debian/patches/65-keyboard-addon-repeated.patch: Do not ignore key
     repeat events in the keyboard addon. Patch taken from
     https://bugs.freedesktop.org/show_bug.cgi?id=9767, thanks to Ryan Lortie.

Changed in hal:
status: Fix Committed → Fix Released

I deliberately did not forward this bug upstream, because the affected FDI rule was still an Ubuntu specific patch (and thus got reverted now). I let them 'mature' in Ubuntu for a while to make sure that they do not cause ill effects with other hardware.

Thus I think that this can be closed.

Changed in hal:
status: Unknown → Rejected

Backported hal breaks this again.

Tormod Volden (tormodvolden) wrote :

Yes, it's broken again in 0.5.9-1ubuntu2~feisty1.

Changed in hal:
status: Fix Released → Confirmed
Tormod Volden (tormodvolden) wrote :

And now /usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi belongs to the hal-info package...

Stefan Nagy (stefan-nagy) wrote :

I can confirm that bug.

DistroRelease: Ubuntu 7.04
Uname: Linux rosa 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
Device (output of lsusb): Bus 004 Device 003: ID 090c:1000 Feiya Technology Corp. Memory Bar

The output of lshal ist attached.

Jon Tai (jontai) wrote :

Just installed Gutsy Tribe 4, and I'm seeing the problem again.

Kenneth Mokkelbost (kmokk) wrote :

Please remove the entry for "Feiya Technology Corp Memory Bar" from 10-usb-music-players.fdi in current (feisty and gutsy) hal. Also, Feiya Technology Corp is today known as Silicon Motion, Inc so I guess all references to 090c should be changed from Feiya Technology to Silicon Motion?

Roman Polach (rpolach) wrote :

Problem still present in Gutsy Beta.
It is very annoying because every time I insert my USB flash disk,
it launches Rythmox(?) and then freezes..

Lee.Tambiah (flossgeek) wrote :

I also get the same issue with my "LG USB Flash Drive".

Output of "lsusb"

Bus 003 Device 001: ID 0000:0000
Bus 005 Device 006: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 03f0:8604 Hewlett-Packard
Bus 001 Device 005: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 001 Device 001: ID 0000:0000

DP (pederiva.d) wrote :

Hi there, I'm having the same problem with this drive: Bus 005 Device 006: ID 090c:1000 Feiya Technology Corp. Memory Bar

I solved as follows:

cd /usr/share/hal/fdi/information$ cd 10freedesktop/
sudo gedit sudo gedit 10-usb-music-players.fdi

removed this entry (which actually is my usbkey):

<!-- Feiya Technology Corp Memory Bar -->
        <match key="@storage.originating_device:usb.vendor_id" int="0x090c">
          <match key="@storage.originating_device:usb.product_id" int="0x1000">
            <merge key="portable_audio_player.type" type="string">generic</merge>
            <merge key="portable_audio_player.access_method" type="string">storage</merge>
            <append key="portable_audio_player.input_formats" type="strlist">audio/mpeg</append>
          </match>
        </match>

and saved the file.

Now everything is fine. Let's hope this bug to be fixed in the new Gusty release :)

Tormod Volden (tormodvolden) wrote :

 hal-info (20070618-1ubuntu3) gutsy; urgency=low
 .
   * removed Feiya Memory Bar from 10-usb-music-players.fdi since it
     is often not a music player (LP: #90286)

Roman Polach (rpolach) wrote :

For my MyFlash USB memory stick here is additions to
lsusb output and lshal output when I plug it:

lsusb_out_diff:
Bus 005 Device 002: ID 090c:1000 Feiya Technology Corp. Memory Bar

lshal_out_diff --- see attachment

Martin Pitt (pitti) on 2007-10-02
Changed in hal-info:
status: Confirmed → In Progress
Tormod Volden (tormodvolden) wrote :

hal-info (20070618-1ubuntu3) gutsy; urgency=low

  * removed Feiya Memory Bar from 10-usb-music-players.fdi since it
    is often not a music player (LP: #90286)

 -- Tormod Volden <email address hidden> Mon, 01 Oct 2007 22:38:27 +0200

Changed in hal-info:
status: In Progress → Fix Released
Roman Polach (rpolach) wrote :

Will the fix be also released for feisty?

Tormod Volden (tormodvolden) wrote :

> Will the fix be also released for feisty?

I believe this was fixed in Feisty proper, but a newer version in the "backports" repository would break it again.

dcberg (david-sipsolutions) wrote :

Hey! This bug is old, but I get the same bug on 9.10 with my Sony pen drive. Maybe I can provide the output of "lsusb" and "lshal" later this weekend – the Ubuntu is on my girlfriends computer.

Changed in hal:
importance: Unknown → Low
status: Invalid → Won't Fix
Changed in hal:
importance: Low → Unknown
Changed in hal:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.