Sweex MP4 player found with USB ID 177f:0460

Bug #647564 reported by jan on 2010-09-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal-info

I have just bought a Sweex MP4 player with USB ID 177f:0460 .
On the outside, it is indistinguishable from the other stick I bought at the same time, with USB ID 10d6:1101

The latter stick was recognized as audio player, the 177f:0460 only as storage device.

jan (jan-ubuntu-h-i-s) wrote :

Adding the following lines to /usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi

        <!-- Sweex: likeFoston, MPMan, Actions Semiconductor -->
        <match key="@storage.originating_device:usb.vendor_id" int="0x177f">
          <!-- Foston 128/256MB / MPMan MP-Ki 128 Player, A similar 2GB MP3 Player -->
          <match key="@storage.originating_device:usb.product_id" int_outof="0x0460">
            <addset key="portable_audio_player.access_method.protocols" type="strlist">storage</addset>
            <merge key="portable_audio_player.folder_depth" type="int">1</merge>
            <append key="portable_audio_player.output_formats" type="strlist">audio/x-ms-wma</append>
            <append key="portable_audio_player.output_formats" type="strlist">audio/x-wav</append>
            <append key="portable_audio_player.input_formats" type="strlist">audio/x-wav</append>
          </match>
        </match>

and executing
   /etc/init.d/hal restart

fixed the problem. How can this be incorporated into the hal databases ?

Xandru (xandruarmesto) wrote :

I have the same problem with device ID 177f:0510 and I've tried the solution below but It doesn't work on Ubuntu 11.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hal-info (Ubuntu):
status: New → Confirmed
jan (jan-ubuntu-h-i-s) wrote :

> First of all, I don't have 10freedesktop folder on my computer. In my
> case is /usr/share/hal/fdi/information/20thirdparty so I've tried:
> - Create 10freedesktop folder and made 10-usb-music-players.fdi file.
> - Put 10-usb-music-players.fdi file on 20thirparty.
> - Modify 20-libmtp9.fdi on 20htirdparty.
>
> I reboot everytime I made a change there but nothing works.
>
Just guessing:

Have you tried replacing the lines

        <match key="@storage.originating_device:usb.vendor_id" int="0x177f">
          <match key="@storage.originating_device:usb.product_id" int_outof="0x0460">

with

      <match key="usb.vendor_id" int="0x177f">
        <match key="usb.product_id" int="0x0460">

in 20-libmtp9.fdi
I see a different syntax on that file on my Ubuntu 10.4 system

It doesn't work neither, I think that file is only for mtp devices.
The syntax is:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<!-- This file was generated by
/build/buildd/libmtp-1.1.0/util/.libs/lt-mtp-hotplug - - fdi -->
<deviceinfo version="0.2">
  <device>
    <match key="info.subsystem" string="usb">
      <!-- Creative ZEN Vision -->
      <match key="usb.vendor_id" int="0x041e">
        <match key="usb.product_id" int="0x411f">
          <match key="info.capabilities" contains_not="portable_audio_player">
            <append key="info.capabilities"
type="strlist">portable_audio_player</append>
          </match>
          <merge key="info.vendor" type="string">Creative</merge>
          <merge key="info.product" type="string">ZEN Vision</merge>
          <merge key="info.category" type="string">portable_audio_player</merge>
          <merge key="portable_audio_player.access_method"
type="string">user</merge>
          <match key="portable_audio_player.access_method.protocols"
contains_not="mtp">
            <append
key="portable_audio_player.access_method.protocols"
type="strlist">mtp</append>
          </match>
          <append key="portable_audio_player.access_method.drivers"
type="strlist">libmtp</append>
          <match key="portable_audio_player.output_formats"
contains_not="audio/mpeg">
            <append key="portable_audio_player.output_formats"
type="strlist">audio/mpeg</append>
          </match>
          <match key="portable_audio_player.output_formats"
contains_not="audio/x-ms-wma">
            <append key="portable_audio_player.output_formats"
type="strlist">audio/x-ms-wma</append>
          </match>
          <merge key="portable_audio_player.libmtp.protocol"
type="string">mtp</merge>
        </match>
      </match>
  </device>
</deviceinfo>

There is another file on the same folder for apple devices
(31-apple-mobile-device). The syntax is:

<?xml version="1.0"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.subsystem" string="usb">
      <match key="usb.vendor_id" int="0x05ac">
        <match key="usb.product_id" compare_ge="0x1290">
          <match key="usb.product_id" compare_le="0x12af">
            <match key="usb.interface.number" int="0x1">
              <append key="info.capabilities" type="strlist">afc</append>
            </match>
          </match>
        </match>
      </match>
    </match>
  </device>
</deviceinfo>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers