Dell Bluetooth Keyboard [Logitech MX5000] multimedia keys don't work

Bug #473641 reported by Stuart Read on 2009-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal-info

This is a Dell Bluetooth Mouse and Keyboard combo with a dongle. Here are the usb IDs:

Bus 003 Device 004: ID 046d:c70a Logitech, Inc. MX5000 Cordless Desktop
Bus 003 Device 003: ID 046d:c70e Logitech, Inc. MX1000 Bluetooth Laser Mouse
Bus 003 Device 002: ID 046d:0b02 Logitech, Inc. BT Mini-Receiver (HID proxy mode)

None of the multimedia keys work. Reading through Bug #321740 I tried the following:

"
1) Run "killall gnome-settings-daemon"
2) Run "xev"
3) Press your non-functioning multimedia keys and then post any output that appears from xev in to this bug report
"
Nothing happens.

"
switch to a terminal (CTRL+ALT+F1) and try the following:

1) Run "sudo showkey -k" and press the keys that don't work. Could you note any keycodes, and which keys they belong too (if you see any).
2) Could you also do the same, but with "sudo showkey -s", and note any scancodes.
"
Also no response.

Could this have anything to do with the bluetooth dongle being in HID proxy mode? For the record, I prefer this over the 9.04 behaviour where I had to un-plug and re-plug the dongle to force this mode since I multi-boot this system and re-connecting bluetooth input every time I switch OSs would be a huge pain.

Thanks!

ProblemType: Bug
Architecture: i386
Date: Tue Nov 3 20:54:46 2009
Dependencies:

DistroRelease: Ubuntu 9.10
Package: hal-info 20090716-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA.UTF-8
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: hal-info
Uname: Linux 2.6.31-14-generic i686

Stuart Read (sread) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers