[Acer TravelMate 4002WLMi] Resume from suspend fails

Bug #360635 reported by Cory Snider on 2009-04-13
2
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Undecided
Unassigned

Bug Description

The system suspends, but it fails to wake. When it is woken up, the fan turns on, the hard drive clicks a couple of times, and the display stays blank with the backlight off. The computer is completely unresponsive, not even responding to Caps Lock.
When I restart the computer, Apport does not start.

This bug may be related to
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/350351
but the underlying cause may be different, as my system contains an Intel 845GM graphics card, not an ATi.

Suspend has not worked for several versions of Ubuntu on this machine. I believe that the last version it worked perfectly was 6.10 or 7.04.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 002: ID 046d:c03f Logitech, Inc. UltraX Optical Mouse
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Acer TravelMate 4000
Package: linux-image-2.6.28-11-generic 2.6.28-11.41
ProcCmdLine: root=UUID=d6d05380-174c-4a1c-8a7d-2f121a665eb3 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.41-generic
SourcePackage: linux

Cory Snider (corhere) wrote :
Cory Snider (corhere) wrote :

I have determined the appropriate sleep quirk for my machine. I have tested it, and suspend and resume works successfully in both X and console. I ran the checkbox suspend_test script without any troubles, and hibernate works.

It appears that there are several hardware configurations for the Acer Travelmate 4000, some with ATI graphics, and others with Intel. I suspect that the sleep quirks in the Acer fdi file are for machines with ATI graphics, and are incompatible with intel graphics.

For resume from suspend to work successfully on my machine, it is necessary to set the vbe_post quirk, and not s3_bios or s3_mode.

affects: linux (Ubuntu) → hal-info (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers