Wrong folder information for Cowon audio players

Bug #360575 reported by andre on 2009-04-13
2
Affects Status Importance Assigned to Milestone
HAL
Fix Released
Medium
hal-info (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: hal

My Cowon IAUDIO U2 device stopped working with Rhythmbox and Banshee because HAL stopped reporting 'MUSIC/' as an audio folder. Also, HAL is erroneously reporting that the device supports folders.

I also found some superfluous folders for IAUDIO U3: 'RECORDS/MUSIC', 'RECORDS/FM', 'RECORDS/VOICE' that are not referenced in the product manual (http://www.cowonamerica.com/download/iaudio_u3_manual.html). IAUDIO U3 only uses three folders 'MUSIC/', 'RECORD/' and 'VOICE/'

The problem is found in 10-usb-music-players.fdi.

I have attached a patch for the problem.

Ubuntu Jaunty 9.04.
hal 0.5.12~rc1+git20090403-0ubuntu1

Related branches

andre (andrerobot) wrote :

Binary package hint: hal

My Cowon IAUDIO U2 device stopped working with Rhythmbox and Banshee because HAL stopped reporting 'MUSIC/' as an audio folder. Also, HAL is erroneously reporting that the device supports folders.

I also found some superfluous folders for IAUDIO U3: 'RECORDS/MUSIC', 'RECORDS/FM', 'RECORDS/VOICE' that are not referenced in the product manual (http://www.cowonamerica.com/download/iaudio_u3_manual.html). IAUDIO U3 only uses three folders 'MUSIC/', 'RECORD/' and 'VOICE/'

The problem is found in 10-usb-music-players.fdi.

I have attached a patch for the problem.

Ubuntu Jaunty 9.04.
hal 0.5.12~rc1+git20090403-0ubuntu1

andre (andrerobot) wrote :
Changed in hal:
status: Unknown → Confirmed

Fixed in 86a4757914cc51602c05147f45592869c11bbacc

Martin Pitt (pitti) wrote :

Fixed upstream.

affects: hal (Ubuntu) → hal-info (Ubuntu)
Changed in hal-info (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Committed
Changed in hal:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090602-0ubuntu1

---------------
hal-info (20090602-0ubuntu1) karmic; urgency=low

  * New git snapshot:
    - Fix regression: Resume on Presario V2000 notebook leaves backlight off.
      (LP: #336521)
    - Add Philips SA52XX portable audio player. (LP: #355520)
    - Add keymap for X200 tablet. (LP: #356019)
    - Fix wrong folder information for Cowon audio players (LP: #360575)
    - Lots of other fixes.
  * debian/rules: Disable keymaps, handled by udev-extras now.

 -- Martin Pitt <email address hidden> Tue, 02 Jun 2009 12:48:56 +0200

Changed in hal-info (Ubuntu):
status: Fix Committed → Fix Released
Changed in hal:
importance: Unknown → Medium
Changed in hal:
importance: Medium → Unknown
Changed in hal:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.