Sansa Fuze not listed as supporting Vorbis and FLAC

Bug #345249 reported by James Henstridge on 2009-03-19
4
Affects Status Importance Assigned to Milestone
HAL
Fix Released
Medium
hal-info (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: hal-info

The 10-usb-music-players.fdi file does not list Fuze players as supporting Vorbis or FLAC audio. I recently bought such a player (what appears to be version 1 of the device) and its firmware supported these formats out of the box.

With the FDI files in intrepid, copying music with Rhythmbox entailed unnecessary and slow transcoding and resulted in all the music being listed as unknown artist and album (in fact they appeared to be untagged). After updating the FDI file, it just copies the music directly.

I filed an upstream bug with the updated FDI file:

    http://bugs.freedesktop.org/show_bug.cgi?id=20616

This consolidates the entries for the Clip and Fuze devices and adds device IDs for Fuze v2 devices. There is a total of 8 device IDs because the players present different IDs depending on whether they are in MSC or MTP/Auto modes.

Related branches

Playing with the settings, the device can also report a product ID of 0x74c0 if I switch it from MSC mode to either MTP or "Auto Detect".

MTP access is enabled for both modes that present this product ID, and for "MTP" mode, mass storage class access is disabled entirely.

The list of supported media types should not depend on the product ID though.

Created an attachment (id=23993)
0001-Merge-the-rules-for-SanDisk-Clip-Fuze-and-SanDisk.patch

Here is a patch that merges the rules for "Sansa Clip/Fuze" with "Sansa Clip Version II".

I checked and FLAC also plays on my version 1 Fuze, and the additional audio_folders are present too.

I don't think there is any easy way to detect if a particular device has an old firmware, and they are selling version 1 Fuzes with vorbis/flac capable firmware installed so it seems reasonable to list the extra formats.

I also took the liberty of adding the two USB IDs for the version 2 Fuze (snarfed from http://ubuntuforums.org/archive/index.php/t-1041356.html).

James Henstridge (jamesh) wrote :

Binary package hint: hal-info

The 10-usb-music-players.fdi file does not list Fuze players as supporting Vorbis or FLAC audio. I recently bought such a player (what appears to be version 1 of the device) and its firmware supported these formats out of the box.

With the FDI files in intrepid, copying music with Rhythmbox entailed unnecessary and slow transcoding and resulted in all the music being listed as unknown artist and album (in fact they appeared to be untagged). After updating the FDI file, it just copies the music directly.

I filed an upstream bug with the updated FDI file:

    http://bugs.freedesktop.org/show_bug.cgi?id=20616

This consolidates the entries for the Clip and Fuze devices and adds device IDs for Fuze v2 devices. There is a total of 8 device IDs because the players present different IDs depending on whether they are in MSC or MTP/Auto modes.

Changed in hal:
status: Unknown → Confirmed

Committed, thank you!

Martin Pitt (pitti) wrote :

Committed upstream.

Changed in hal-info (Ubuntu):
assignee: nobody → pitti
status: New → Fix Committed
Changed in hal:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090324-0ubuntu1

---------------
hal-info (20090324-0ubuntu1) jaunty; urgency=low

  * New git snapshot:
    - Ignore U3 (Windows software) on SanDisk Cruzer Titanium (LP: #347457)
    - Nokia 5300 mobile phone modem (LP: #329633)
    - Insignia Pilot portable audio player (LP: #335965)
    - Fix Acer Aspire 5920G keymap (LP: #338328)
    - Sansa Fuze not listed as supporting Vorbis and FLAC (LP: #345249)

 -- Martin Pitt <email address hidden> Wed, 25 Mar 2009 10:54:08 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Changed in hal:
importance: Unknown → Medium
Changed in hal:
importance: Medium → Unknown
Changed in hal:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.