regression: resume on Presario V2000 notebook leaves backlight off

Bug #336521 reported by jepler on 2009-03-02
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt
Nominated for Hardy by jepler
Nominated for Intrepid by Mark Stosberg
Nominated for Jaunty by Mark Stosberg
Karmic
Medium
Unassigned

Bug Description

Binary package hint: hal-info

Ubuntu Hardy, gnome desktop
Bad package version: 20090128-0ubuntu1~hardy2
Good package version: 20081124-0ubuntu1~hardy

To reproduce: press Fn-F5 (suspend). After suspend process is complete, press power button to resume.

Expected behavior: backlight turns on
Actual behavior: backlight stays off

The machine is still working fine at this point--accepts ssh connections, and ctrl-alt-backspace causes lots of disk activity so it appears the X server is still running.

Downgrading to hal-info 20081124-0ubuntu1~hardy fixes the problem and allows suspend/resume cycles to work.

$ lshal | grep system.hardware.product
  system.hardware.product = 'Presario V2000 (EH593AV#ABA)' (string)

Related branches

jepler (jepler) wrote :

This may be a duplicate of LP#334712, but I'm not sure.

wirehead (wirehead) wrote :

I'm confirming this with Intrepid on a Sony VAIO VGN-T140P. I initially ran into this problem on upgrade to Intrepid, fixed it by changing some of the quirks lines in /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux. The following package upgrade broke it again:

hal-info (20081124-0ubuntu1~intrepid) to 20090128-0ubuntu1~intrepid2

Downgrading the package in Synaptic fixed it for me as well, but is obviously not the best solution.

More info: http://ubuntuforums.org/showthread.php?p=6840753#post6840753 (my post is at the end).

Let me know if I can provide any other info to help fix this.

Mark Stosberg (markstos) wrote :

I can confirm this bug with Intrepid on a Sony Vaio, model PCG-8X2L.

Mark Stosberg (markstos) wrote :

I can also confirm the fix described here:

- downgrade and pin hal-info to the version that originally came with Intrepid
- Add the 3 lines to a file described here:
  http://ubuntuforums.org/showpost.php?p=6355179&postcount=13

After that, I can press the power button for a successful suspend

Pat McGowan (pat-mcgowan) wrote :

Confirmed in Jaunty on a Sony PCG-5B1L, backlight is off on resume, worked in Hardy

Fixed by modifying usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-sony.fdi to add my system platform name VGN-B100B(UC) to get the quirk it needs.

 <match key="system.hardware.product" contains_outof="VGN-FS730;PCG-FX405;V
GN-C2S_G;VGN-B1XP;VGN-FE21B;VGN-B100B(UC)">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
  </match>

Mark Stosberg (markstos) wrote :

Pat,

How did you determine your system platform name to add it there?

   Mark

Pat McGowan (pat-mcgowan) wrote :

lshal | grep system.hardware.product
or
sudo dmidecode | grep -i platform

Stephen Cradock (s-cradock) wrote :

This problem seems to be due to a change in the way the quirks are set - it is now done straight out of the HAL database, rather than from the config file. How are we supposed to know this????????

The quirk keys can be set to new values by hand using the hal-set-property, after parsing the output of

lshal | grep "quirk"

to find the correct key name. The syntax is:

sudo hal-set-property --udi '/org/freedesktop/Hal/devices/computer' --key "power_management.quirk.dpms_suspend" --bool "false"

to set QUIRK-DPMS-SUSPEND to false, for instance.

Hope that helps....

jepler (jepler) wrote :

Regardless of what the workarounds may be, this is an important regression and should be fixed by a new package.

Stephen Cradock (s-cradock) wrote :

You're right; the workaround I gave only works until the next re-boot, because the values from hal-info now over-write the old values. That seems to have been the significant change in the new version - it doesn't do that in Intrepid, but it now does in Jaunty.

What is actually needed is to get the correct quirks into the .fdi files in /usr/share/hal/fdi/information/10freedesktop. Yours should be in 20-video-quirk-pm-sony.fdi. In my case I added an appropriate identifier for my machine (in the corresponding 20-v-q-pm-hp.fdi) to a case that set power_management.quirk.none to true. Now mine works sometimes!

Stephen Cradock (s-cradock) wrote :

Oops! sorry - see you have a Presario, not a Sony. Same method, different file......

Matt Zimmerman (mdz) on 2009-04-28
Changed in hal-info (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) on 2009-04-28
Changed in hal-info (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

This bug amalgated suspend regressions for various machine types. Let's use this for the Presario one, as originally reported and stated in the bug title.

Can you please do "lshal > /tmp/hal.txt" and attach /tmp/hal.txt here?

I fixed the Sony one from Pat McGowan upstream in commit c4f7ec3.

Changed in hal-info (Ubuntu Karmic):
status: In Progress → Incomplete
jepler (jepler) wrote :

Attaching output of 'lshal' from the Presario V2000 as requested

Martin Pitt (pitti) wrote :

jepler, thank you! Can you now please follow http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-debug.html to find out which particular quirks your machine needs?

Thanks!

Martin Pitt (pitti) wrote :

not a karmic release blocker, moving to "floating" task.

Changed in hal-info (Ubuntu Karmic):
status: Incomplete → Won't Fix
assignee: Martin Pitt (pitti) → nobody
Martin Pitt (pitti) wrote :

Still waiting for jepler's response (see comment 14), leaving as "incomplete".

jepler (jepler) wrote :

The required quirk seems to be power_management.quirk.dpms_on

Martin Pitt (pitti) on 2009-05-12
Changed in hal-info (Ubuntu):
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :

Committed upstream.

Changed in hal-info (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090602-0ubuntu1

---------------
hal-info (20090602-0ubuntu1) karmic; urgency=low

  * New git snapshot:
    - Fix regression: Resume on Presario V2000 notebook leaves backlight off.
      (LP: #336521)
    - Add Philips SA52XX portable audio player. (LP: #355520)
    - Add keymap for X200 tablet. (LP: #356019)
    - Fix wrong folder information for Cowon audio players (LP: #360575)
    - Lots of other fixes.
  * debian/rules: Disable keymaps, handled by udev-extras now.

 -- Martin Pitt <email address hidden> Tue, 02 Jun 2009 12:48:56 +0200

Changed in hal-info (Ubuntu Karmic):
status: Won't Fix → Fix Released
Martin Pitt (pitti) on 2009-07-18
Changed in hal-info (Ubuntu Karmic):
status: Fix Released → Triaged
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers