Fix Fn+Arrow "Brightness Up" key on Acer laptops

Bug #327707 reported by Fred on 2009-02-10
18
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: hal-info

Using Jaunty alpha 4 with all available updates.

On my laptop Acer TravelMate 6292, the keys Fn+Arrow Right ("Brightness Up" key) sends plusminus and XF86MonBrightnessUp keysyms.
Here is the output of xev when I pressed Fn+Arrow Right:
$ xev | sed -n 's/^.*state \([0-9].*\), keycode *\([0-9]\+\) *\(.*\), .*$/keycode \2 = \3, state = \1/p'
keycode 126 = (keysym 0xb1, plusminus), state = 0x10
keycode 233 = (keysym 0x1008ff02, XF86MonBrightnessUp), state = 0x10
keycode 233 = (keysym 0x1008ff02, XF86MonBrightnessUp), state = 0x10
keycode 126 = (keysym 0xb1, plusminus), state = 0x10
keycode 233 = (keysym 0x1008ff02, XF86MonBrightnessUp), state = 0x10
keycode 233 = (keysym 0x1008ff02, XF86MonBrightnessUp), state = 0x10

By the way I don't why _one_ key press send 6 events...

By remapping the scancode e04e to XF86MonBrightnessUp in the /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi file, everything works now.
A patch is attached doing that.
Please note that several Acer models are impacted by this :
- Acer Aspire One : http://crunchbanglinux.org/wiki/howto/aspireone (It advises the same fix)
- Acer 5920 (all variant) : http://ubuntuforums.org/showpost.php?p=6067640&postcount=28
In the patch, remapping is only done for TravelMate 6292 but may be we should generalize it to all acer models ?
I don't have enough experience to judge the risks.

Related branches

C. Cooke (ccooke) wrote :

Hi, thanks for taking the time to submit a bug report.

It would be really useful if you could confirm the version of hal-info you have installed - the output of 'apt-cache policy hal-info' would be perfect.

Thank you

Fred (frederic-lespez) wrote :

Here is the information you asked :

# apt-cache policy hal-info
hal-info:
  Installé : 20090210-0ubuntu1
  Candidat : 20090210-0ubuntu1
 Table de version :
 *** 20090210-0ubuntu1 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "Fix Fn+Arrow Right ("Brightness Up" key) sends plusminus keysyms" was not flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug and this attachment is one! Subsequently, I've checked the patch flag for it. In the future when submitting patches please use the patch checkbox as there are some Launchpad searches that use this feature. Thanks for your contribution Fred!

Changed in hal-info:
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) wrote :

That was already fixed in a more generic fashion in hal-info trunk. Will upload to Jaunty soon.

Changed in hal-info:
assignee: nobody → pitti
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090227-0ubuntu1

---------------
hal-info (20090227-0ubuntu1) jaunty; urgency=low

  * New git snapshot:
    - Hotkeys for Fujitsu Siemens Amilo Si 1520 (LP: #317505)
    - Fix Fn+Arrow "Brightness Up" key on Acer laptops (LP: #327707)
    - UM175 modem (LP: #328309)
    - Sleep quirks for HP nw8440 (LP: #328522)
    - Samsung YP-S2 audio player (LP: #331538)
    - Samsung YP-S5 audio player (LP: #332913)
    - Fix Samsung Q210 brightness keys (LP: #333352)
    - Sony Ericsson w880i/3G mobile modem (LP: #334327)

 -- Martin Pitt <email address hidden> Fri, 27 Feb 2009 11:14:51 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
FokkerCharlie (charlie-andrews) wrote :

Is a fix available to those of us running Intrepid/Hardy?

Charlie

FokkerCharlie [2009-02-27 12:46 -0000]:
> Is a fix available to those of us running Intrepid/Hardy?

You can go to

  http://archive.ubuntu.com/ubuntu/pool/main/h/hal-info/

and install the latest version (from jaunty) by clicking on it (you'll
get gdebi).

Eventually we'll backport newer hal-infos to intrepid/hardy as well,
but they need to settle for a while and get tested.

Feedback appreciated!

FokkerCharlie (charlie-andrews) wrote :

OK, I tested this, and it sort of works OK.

Output from one brightness down followed by one brightness up press:

[CODE]~$ xev |grep keycode
    request MappingKeyboard, first_keycode 8, count 247
    request MappingKeyboard, first_keycode 8, count 248
    request MappingKeyboard, first_keycode 8, count 247
    request MappingKeyboard, first_keycode 8, count 248
    request MappingKeyboard, first_keycode 8, count 247
    request MappingKeyboard, first_keycode 8, count 248
    request MappingKeyboard, first_keycode 8, count 247 [/CODE]

In practical terms, each press seems to give one or two steps on the brightness scale, and a bit of a flicker. It is usable, but a bit ugly.

Also, my bluetooth button effects one brightness increment, and if held down smoothly increases the brightness; as such works slightly better than the increase brightness button!

Any thoughts? Standing by to provide more info.

Charlie

Fred (frederic-lespez) wrote :

On my laptop (Acer TravelMate 6292), the bug is fixed : Fn+Arrow Right ("Brightness Up" key) doesn't send plusminus any more. And I don't see any regressions.

FokkerCharlie :
For the bluetooth key that change brightness, did you see that bug #327614 ?
https://bugs.launchpad.net/ubuntu/+bug/327614
What model of Acer laptop do you have ?

For the problem about brightness keys changing brightness by one or two steps one keypress, see bug #332548:
https://bugs.launchpad.net/ubuntu/+bug/332548

Do not hesitate to add comments if you experience the same problems. Do not forget to precise the model of your Acer laptop.
You will also find a lot of useful information to diagnose problem on this page :
https://wiki.ubuntu.com/Hotkeys/Troubleshooting

Fred (frederic-lespez) wrote :

Under Intrepid, it also works : no plusminus anymore when pressing Fn+Arrow Right ("Brightness Up" key).
I have done some tests : I don't see any regressions for now. Looks goods for my laptop model (Acer TravelMate 6292) :-)

Fred

I have fixed the bluetooth key problem by using the fdi here http://launchpadlibrarian.net/20159357/30-keymap-acer.fdi .

I have read bug 332548, but am not sure what I am meant to do with it! Can you give us a clue?

My lappy in an Acer Aspire 5920G - 302G25MI .

Charlie

Alkis Georgopoulos (alkisg) wrote :

In the first bug report (https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/281951) I've uploaded the .fdi file which works fine with my Acer 5920G laptop, after spending hours on it.

I'm attaching here the latest version, you may use it if you like.
It fixes the bluetooth key.
Also, it handles the brightness keys as informational-only ("reserved"), 'cause otherwise they are received as normal keystrokes - e.g. they cancel full-screen playback in youtube.

OK, what now works for me is:

Using Alkis' fdi, and adding:

acpi_backlight=vendor

to the boot parameters in menu.lst. I guess that using that fdi overwrites any changes I made by downloading the patch from Martin, but there you go! Now it's perfect.

Charlie

Martin Pitt (pitti) wrote :

Alkis,

this bug report is already closed.

Can you please create a new bug report and include the output of "lshal -u /org/freedesktop/Hal/devices/computer"?

I tried to compare your fdi against the current version, but it's quite an unintelligible delta. I reduced it to

- <append key="input.keymap.data" type="strlist">e054:bluetooth</append> <!-- Bluetooth (toggle) off-to-on -->
- <append key="input.keymap.data" type="strlist">e059:brightnessup</append> <!-- Fn+Right Brightness Up -->
+ <append key="input.keymap.data" type="strlist">e00a:media</append> <!-- TV button -->
+ <append key="input.keymap.data" type="strlist">e059:bluetooth</append> <!-- Bluetooth (toggle) -->
+ <append key="input.keymap.data" type="strlist">e06c:mail</append> <!-- Mail button -->
+ <append key="input.keymap.data" type="strlist">e032:www</append> <!-- WWW button -->
+ <append key="input.keymap.data" type="strlist">e05f:sleep</append> <!-- Fn+F4 -->
+ <append key="input.keymap.data" type="strlist">e020:mute</append> <!-- Fn+F8 -->
+ <append key="input.keymap.data" type="strlist">e012:sport</append> <!-- Kid icon, Acer Arcade -->
+ <append key="input.keymap.data" type="strlist">e022:playpause</append> <!-- Fn+Home -->
+ <append key="input.keymap.data" type="strlist">e024:stopcd</append> <!-- Fn+PgUp -->
+ <append key="input.keymap.data" type="strlist">e010:previoussong</append> <!-- Fn+PgDn -->
+ <append key="input.keymap.data" type="strlist">e019:nextsong</append> <!-- Fn+End -->
+ <append key="input.keymap.data" type="strlist">e02e:volumedown</append> <!-- Volume Down -->
+ <append key="input.keymap.data" type="strlist">e030:volumeup</append> <!-- Volume Up -->

I see that you changed the bluetooth key; this would then require a model specific stanza.

I'd like to get this fixed upstream properly.

Can you please try the current version (attached), and tell me in the newly filed bug which keys are still not working? In that version I already fixed the bluetooth key, please let me know if it does the right thing now.

Please install it with

  sudo mv /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi.mine # do a backup
  sudo cp 30-keymap-acer.fdi /usr/share/hal/fdi/information/10freedesktop/

and then reboot. Thank you!

Alkis Georgopoulos (alkisg) wrote :

Martin thanks for your interest in properly solving this,

I've filed bug #338328 and send the information you requested there.

Kind regards,
Alkis Georgopoulos

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers