hal-info update causes resume from suspend issue

Bug #315271 reported by gpothier on 2009-01-08
8
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Undecided
Martin Pitt
Hardy
Undecided
Unassigned
Intrepid
Medium
Martin Pitt
Jaunty
Undecided
Martin Pitt

Bug Description

Binary package hint: hal-info

An update to hal-info causes a strange behavior on a Dell Latitude D810 laptop: resuming from suspend with an external monitor plugged in causes the internal monitor to not display anything, regardless of how the external monitor is configured (clone, big desktop, off).
A few details:
- The backlight seems to be turned on.
- Before the hal-info update, when resuming from suspend, the text-console blinking cursor briefly appears on the internal monitor before the desktop shows up; after the update, the cursor appears on the external monitor.

This is 100% reproducible. Upgrading from hal-info 20081013-0ubuntu3 (the version that is on the Intrepid CD) to 20081124-0ubuntu1~intrepid makes the problem appear, downgrading to the former makes the problem disappear.

Martin Pitt (pitti) wrote :

Can you please do

  lshal > /tmp/hal-old.txt

with the downgraded hal-info and attach /tmp/hal-old.txt here. Then upgrade hal-info, reboot, and do

  lshal > /tmp/hal-new.txt

and attach it again? That should tell me your vendor/product IDs, and the changed quirks for your model.

Thanks!

Changed in hal-info:
assignee: nobody → pitti
status: New → Incomplete
gpothier (gpothier) wrote :
gpothier (gpothier) wrote :
Martin Pitt (pitti) wrote :

The update enabled two quirks which apparently shouldn't be used on your machine:

+ power_management.quirk.vbe_post = true (bool)
+ power_management.quirk.vbemode_restore = true (bool)

Changed in hal-info:
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :
Changed in hal-info:
status: In Progress → Fix Committed
status: New → In Progress
importance: Undecided → Medium
Martin Pitt (pitti) on 2009-02-01
Changed in hal-info:
assignee: nobody → pitti
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090202-0ubuntu1

---------------
hal-info (20090202-0ubuntu1) jaunty; urgency=low

  * New upstream git snapshot:
    - Now has all suspend quirks from acpi-support
      (UbuntuSpec:acpi-support-deprecation).
    - Add Motorola E770V modem. (LP: #321485)
    - Fix suspend regression on Dell Latitude D810. (LP: #315271)
  * Drop 01_convert-keymaps-to-use-X11-friendly-symbols.patch,
    committed upstream.

 -- Martin Pitt <email address hidden> Mon, 09 Feb 2009 14:45:06 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

New hal-info uploaded to hardy/intrepid-proposed uploaded which fixes this; waiting for Steve to process.

Changed in hal-info:
status: New → In Progress
Colin Watson (cjwatson) wrote :

Accepted hal-info into hardy-proposed and intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in hal-info:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090128-0ubuntu1~intrepid2

---------------
hal-info (20090128-0ubuntu1~intrepid2) intrepid-proposed; urgency=low

  * Add 01_disable_samsung_nc10_keymap.patch: Disable keymap for
    Samsung NC10, since it causes X freezes on the intrepid kernel.
    (LP: #295251)
  * Add 00git-option_modem_fix.patch: Fix Option Globetrotter HSUPA
    modem (product 0x7211). Backported from git head. (LP: #304818)
  * Add 00git-latitude_d810_suspend.patch: Fix video quirks on Dell
    Latitude D810 (regression in previous intrepid-updates hal-info).
    (LP: #315271)

hal-info (20090128-0ubuntu1~intrepid1) intrepid-proposed; urgency=low

  * New upstream git snapshot:
    - Add Nokia E51 mobile modem (LP: #261416)
    - Add Nokia N and E series modems (LP: #303748)
    - Add ATT USBConnect Mercury modem (LP: #306604)
    - Add Sony Ericsson W890i music player (LP: #314618)
    - Fix detection of AT&T Option 3G modems again (LP: #316120)
    - Add ZTE AC8700 (EV-DO) modem (LP: #321213)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 13:43:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090128-0ubuntu1~hardy2

---------------
hal-info (20090128-0ubuntu1~hardy2) hardy-proposed; urgency=low

  * Add 01_disable_samsung_nc10_keymap.patch: Disable keymap for
    Samsung NC10, since it causes X freezes on the intrepid kernel.
    (LP: #295251)
  * Add 00git-option_modem_fix.patch: Fix Option Globetrotter HSUPA
    modem (product 0x7211). Backported from git head. (LP: #304818)
  * Add 00git-latitude_d810_suspend.patch: Fix video quirks on Dell
    Latitude D810 (regression in previous intrepid-updates hal-info).
    (LP: #315271)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 13:43:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
HeWhoE (hewhoe) wrote :

This update for hardy broke resume from suspend for me. I had to downgrade back to 20080317+git20080318-1ubuntu4 to get it to work again. With the update, when I resumed my laptop from suspend, the system came back up, but the laptop screen didn't.

gpothier (gpothier) wrote :

The bug is fixed for me now, thanks.

gpothier (gpothier) wrote :

Hmmm, I spoke too fast, sometimes when the external monitor is unplugged when I resume from suspend, the internal monitor fails to turn on. It turns on when I plug in the external monitor and activate it with xrandr (I have a keyboard shortcut to activate it so I can do that with the internal screen turned off).
Moreover, a rather unhealthy stroboscopic blinking of random white bands occurs on the internal monitor when I go to suspend (it stops when the machine reaches the suspended state).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers