Add support for Option Globetrotter HSUPA modem (0af0:7211) found in Acer Aspire One

Bug #304818 reported by Kenneth Mokkelbost on 2008-12-03
8
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: hal-info

This patch will add support for the HSUPA modem found in Acer Aspire One.

--- 10-modem.fdi 2008-12-03 15:10:30.000000000 +0100
+++ 10-modem.fdi 2008-12-03 15:16:25.000000000 +0100
@@ -84,7 +84,7 @@
           </match>
         </match>

- <match <email address hidden>:usb.product_id" int_outof="0x7011">
+ <match <email address hidden>:usb.product_id" int_outof="0x7011;0x7211">
           <match <email address hidden>:usb.interface.number" int="2">
             <append key="modem.command_sets" type="strlist">GSM-07.07</append>
             <append key="modem.command_sets" type="strlist">GSM-07.05</append>

Kenneth Mokkelbost (kmokk) wrote :
description: updated
description: updated
Changed in hal-info:
importance: Undecided → Medium
status: New → Triaged

Thanks for your work. Here is a debdiff that fixes it for Jaunty.

Bryce Harrington (bryce) wrote :

Looks good, upload sponsored.

Changed in hal-info:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20081127-0ubuntu3

---------------
hal-info (20081127-0ubuntu3) jaunty; urgency=low

  * Add 04_globetrotter_hsupa_modem to support Option Globetrotter
    HSUPA modems (LP: #304818)

 -- Martin Mai <email address hidden> Sat, 10 Jan 2009 11:54:22 -0500

Changed in hal-info:
status: Fix Committed → Fix Released
Kenneth Mokkelbost (kmokk) wrote :

Since Jaunty is still a couple of months away, I feel it also should be added to Intrepid's hal-info.

Martin Pitt (pitti) wrote :

Committed upstream. I'll do a new Jaunty release soon, and will also put the latest hal-info into intrepid/hardy-proposed.

Kenneth Mokkelbost (kmokk) wrote :

Tested todays (Feb 1) livecd and found that my patch is broken by commit 113cbe13dfb3935eeafec66ebbd813b358f7178b in hal-info.

The 0x7011 and 0x7211 should therefore split into separate entries.

Kenneth Mokkelbost (kmokk) wrote :

Change status to New since the released fix doesn't work anymore.

Changed in hal-info:
status: Fix Released → New
Martin Pitt (pitti) wrote :

Committed upstream, thank you!

Changed in hal-info:
assignee: nobody → pitti
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Since half of the fix is already in hardy/intrepid-proposed, I'll backport this other half for stables, too.

Martin Pitt (pitti) wrote :

New hal-info uploaded to hardy/intrepid-proposed uploaded which fixes this; waiting for Steve to process.

Changed in hal-info:
status: New → In Progress
status: New → In Progress
Colin Watson (cjwatson) on 2009-02-10
Changed in hal-info:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted hal-info into hardy-proposed and intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in hal-info:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090210-0ubuntu1

---------------
hal-info (20090210-0ubuntu1) jaunty; urgency=low

  * New upstream git snapshot:
    - Add Option Globetrotter HSUPA modem (0af0:7211) found in Acer
      Aspire One (LP: #304818)
    - Add Sony Ericsson P1i MP3 player for HAL (LP: #305249)
    - Add Nokia N78 and 6500c modems (LP: #322443)
    - Add hotkeys for Samsung X30 (LP: #323689)
    - Fix backlight keys on HP 6730b (LP: #325560)
    - Fix bluetooth hotkey on Acer TM6292 (LP: #327614)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 16:45:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090128-0ubuntu1~intrepid2

---------------
hal-info (20090128-0ubuntu1~intrepid2) intrepid-proposed; urgency=low

  * Add 01_disable_samsung_nc10_keymap.patch: Disable keymap for
    Samsung NC10, since it causes X freezes on the intrepid kernel.
    (LP: #295251)
  * Add 00git-option_modem_fix.patch: Fix Option Globetrotter HSUPA
    modem (product 0x7211). Backported from git head. (LP: #304818)
  * Add 00git-latitude_d810_suspend.patch: Fix video quirks on Dell
    Latitude D810 (regression in previous intrepid-updates hal-info).
    (LP: #315271)

hal-info (20090128-0ubuntu1~intrepid1) intrepid-proposed; urgency=low

  * New upstream git snapshot:
    - Add Nokia E51 mobile modem (LP: #261416)
    - Add Nokia N and E series modems (LP: #303748)
    - Add ATT USBConnect Mercury modem (LP: #306604)
    - Add Sony Ericsson W890i music player (LP: #314618)
    - Fix detection of AT&T Option 3G modems again (LP: #316120)
    - Add ZTE AC8700 (EV-DO) modem (LP: #321213)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 13:43:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20090128-0ubuntu1~hardy2

---------------
hal-info (20090128-0ubuntu1~hardy2) hardy-proposed; urgency=low

  * Add 01_disable_samsung_nc10_keymap.patch: Disable keymap for
    Samsung NC10, since it causes X freezes on the intrepid kernel.
    (LP: #295251)
  * Add 00git-option_modem_fix.patch: Fix Option Globetrotter HSUPA
    modem (product 0x7211). Backported from git head. (LP: #304818)
  * Add 00git-latitude_d810_suspend.patch: Fix video quirks on Dell
    Latitude D810 (regression in previous intrepid-updates hal-info).
    (LP: #315271)

 -- Martin Pitt <email address hidden> Tue, 10 Feb 2009 13:43:24 +0100

Changed in hal-info:
status: Fix Committed → Fix Released
dzenan (dzenan21) on 2009-08-17
Changed in hal-info (Ubuntu Hardy):
status: Fix Released → Confirmed
Changed in hal-info (Ubuntu Intrepid):
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :

Do not change bug statuses without explanation.

Changed in hal-info (Ubuntu Hardy):
status: Confirmed → Fix Released
Changed in hal-info (Ubuntu Intrepid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers