NM 0.7: Motorola V3xx HSDPA phone not detected by probe code (fdi attached)

Bug #267227 reported by andyboeh on 2008-09-06
8
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: network-manager

The Motorola RAZR V3xx HSDPA Phone is not detected by NetworkManager due to missing hal information.

Attached is the file 10-modem.fdi I created in the 20-thirdparty subfolder. The V3xx works perfectly well using GPRS, could not test 3G Mode so far (no coverage).
I don't know whether I got the modem.command_sets right, I basically copied over the E51 description and changed the product ID.

Ubuntu 8.04.1, network-manager 0.7~~svn20080818t061112+eni1-0ubuntu1~nm1~hardy1

-------------

I upgraded to NM 0.7~~svn20080908t183521+eni0-0ubuntu4~nm1~hardy1 which should have the fixed probing-code, but unfortunately, the V3xx is still not detected. Syslog only says: NetworkManager: <debug> [1222098815.086789] probe_modem(): Couldn't get caps

So I tried to manually extract the modem's capabilities using minicom:

AT+GCAP
+GCAP: +FCLASS

OK

Does this mean the V3xx does not correctly announce its caps?

Related branches

andyboeh (andy-boehler) wrote :
description: updated
description: updated
Alexander Sack (asac) wrote :

the idea is to find a solution that doesnt need a patch for each and every modem just because we dont know whether its gsm or cdma.

Changed in network-manager:
importance: Undecided → Medium
milestone: none → ubuntu-8.10-beta
status: New → Confirmed
status: Confirmed → Triaged
andyboeh (andy-boehler) wrote :

I upgraded to NM 0.7~~svn20080908t183521+eni0-0ubuntu4~nm1~hardy1 which should have the fixed probing-code, but unfortunately, the V3xx is still not detected. Syslog only says: NetworkManager: <debug> [1222098815.086789] probe_modem(): Couldn't get caps

So I tried to manually extract the modem's capabilities using minicom:

AT+GCAP
+GCAP: +FCLASS

OK

Does this mean the V3xx does not correctly announce its caps?

Antti Kaijanmäki (kaijanmaki) wrote :

Please, execute `$ lshal > lshal.log' and attach lshal.log to this bug report.

andyboeh (andy-boehler) wrote :

Please find lshal.log attached.

description: updated

With +FCLASS the phone claims to support Fax command set.

I just have to check: Are you absolutely sure that this phone can be used for Internet access with USB cable? :)

Could you please provide the output of 'AT+CGDCONT=?' and 'AT+CGDCONT?' from minicom,

andyboeh (andy-boehler) wrote :

Hehe, yes, I'm really sure internet access works over USB, actually I've been using it for around a year now (using gnome-ppp, and with the 10-modem.fdi posted above using NM 0.7)

So, the output from 'AT+CGDCONT=?' is:

+CGDCONT: (1-3),("IP"),,,(0,1),(0,1)

OK

and the output from 'AT+CGDCONT?' is:

+CGDCONT: 1,"IP","web.yesss.at","0.0.0.0",0,0
+CGDCONT: 2,"","","",0,0
+CGDCONT: 3,"","","",0,0

OK

Antti Kaijanmäki (kaijanmaki) wrote :

(sorry for late reply, I've been awfully busy)

Andy, you were right; the phone doesn't announce it's caps properly. This device must be individually patched in 10-modem.fdi. I don't have time to work on this until next week so I'm assigning this to asac ;-)

Changed in network-manager:
assignee: nobody → asac
Alexander Sack (asac) on 2008-10-03
Changed in network-manager:
milestone: ubuntu-8.10-beta → ubuntu-8.10
Changed in hal-info:
assignee: asac → nobody
Alex_K (alex-keusch) wrote :

I've installed 8.10 beta today and I'm also trying to get connected with my V3xx.

My phone has not been dedected by NM, so I've created the 10-modem.fdi as posted above. Now NM dedects my phone after pluggin it in. At the configuration I've selected my provider (Austria/Drei), so far everything seems to work.
But if I try to initialize the connection through my phone (by clicking "Drei"), NM tries to connect for about a half second, and falls back to the "disconnected" state without a error message.

syslog says "No carrier", but my phone shows a good 3G connection:
Oct 4 14:04:29 xps NetworkManager: <info> Registered on Home network
Oct 4 14:04:30 xps NetworkManager: <info> Associated with network: +COPS: 0,0,"3 AT"
Oct 4 14:04:30 xps NetworkManager: <WARN> dial_done(): No carrier
Oct 4 14:04:30 xps NetworkManager: <info> (ttyACM0): device state change: 4 -> 9
Oct 4 14:04:30 xps NetworkManager: <debug> [1223121870.109800] nm_serial_device_close(): Closing device 'ttyACM0'
Oct 4 14:04:30 xps NetworkManager: <info> Marking connection 'Drei' invalid.
Oct 4 14:04:30 xps NetworkManager: <info> Activation (ttyACM0) failed.

andyboeh (andy-boehler) wrote :

Alex, I'm also on Intrepid now, but for me it's working properly (Provider: yesss/Austria). My log says:

Oct 5 23:42:46 one NetworkManager: <info> (ttyACM0): powering up...
Oct 5 23:42:46 one NetworkManager: <info> Searching for a network...
Oct 5 23:42:46 one last message repeated 10 times
Oct 5 23:42:46 one NetworkManager: <info> Registered on Roaming network
Oct 5 23:42:46 one NetworkManager: <info> Associated with network: +COPS: 0,0,"one"
Oct 5 23:42:46 one NetworkManager: <info> Connected, Woo!

On my phone, I have a connection to "yesss" configured with the same name as in NetworkManager, but I don't think this makes any difference!?

andyboeh (andy-boehler) wrote :

Just remembered that I had a 3 prepaid-SIM lying around so I checked connecting: Again, this works as expected using the entry "Drei" the wizard suggests (and this connection does not exist on my phone).

Alex_K (alex-keusch) wrote :

I did some more tests today.

I've tried to connect with a minimal wvdail.conf as discribed in the wiki on NetworkManager/Hardware/3G/Probing:

Modem = /dev/ttyACM0
Baud = 115200
Init = ATZ
Init2 = AT+CGDCONT=1,"IP","drei.at"
Phone = *99#
Username = dummy
Password = dummy

and I get the same "No carrier" error.

In my working gnomeppp config (attached) i have much more init strings. I have no clue what these strings are doing (copied them from a forum), but can it be that they are needed because of the "Drei" branded firmware of the phone?

Martin Pitt (pitti) wrote :

Committed upstream with missing vendor_id match.

Changed in hal-info:
assignee: nobody → pitti
status: Triaged → Fix Committed
andyboeh (andy-boehler) wrote :

Thanks, Martin (also for fixing the missing vendor_id, I don't know why I forgot to add it to the .fdi)!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20081001+git20081007-0ubuntu1

---------------
hal-info (20081001+git20081007-0ubuntu1) intrepid; urgency=low

  * New git snapshot, with all the currently reported modem and music player
    FDIs from Launchpad committed. (LP: #246741, #261685, #267227, #267727,
    #278458, #278660, #279005, #279182)
  * Drop patches 03_dell_studio.patch and 10-samsung-Q1-keymap.patch,
    committed upstream.

 -- Martin Pitt <email address hidden> Tue, 07 Oct 2008 21:47:56 +0200

Changed in hal-info:
status: Fix Committed → Fix Released
Alex_K (alex-keusch) wrote :

The Drei-branded software of the v3xx really seems to cause the problem with NM.

I've debranded my phone today, flashed it with the original Motorola firmware, and everything works as expected now.

On Wed, Oct 08, 2008 at 01:47:14PM -0000, Alex_K wrote:
> The Drei-branded software of the v3xx really seems to cause the problem
> with NM.
>
> I've debranded my phone today, flashed it with the original Motorola
> firmware, and everything works as expected now.
>

OK, lets file that as a picky firmware issue. Would be nice to know
when this happens though. but i doubt now that you flashed it, we will
never know.

 - Alexander

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers