HAL entries for iRiver E100

Bug #261685 reported by David Hilbig on 2008-08-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: hal

Updated - Additional keys for "audio_folders"

For Hardy Heron 8,04

I have added the following to the iRiver section of 10-usb-music-players.fdi

          <!-- E100 -->
          <match key="@storage.originating_device:usb.product_id" int="0x1041">
            <addset key="portable_audio_player.access_method.protocols" type="strlist">storage</addset>
            <append key="portable_audio_player.output_formats" type="strlist">audio/x-ms-wma</append>
            <append key="portable_audio_player.output_formats" type="strlist">application/ogg</append>
            <append key="portable_audio_player.input_formats" type="strlist">audio/mpeg</append>
            <append key="portable_audio_player.playlist_format" type="strlist">audio/x-iriver-pla</append>
            <append key="portable_audio_player.playlist_path" type="strlist">Playlists/%File</append>
            <append key="portable_audio_player.audio_folders" type="strlist">Music/</append>
            <append key="portable_audio_player.audio_folders" type="strlist">Recordings/</append>
       </match>

lsusb gave the following information

Bus 005 Device 005: ID 4102:1041 iRiver, Ltd.

This has made it appear on the desktop with the appropriate icon and Rhythmbox and Banshee both see it as a device.

Related branches

description: updated
Chris Coulson (chrisccoulson) wrote :

Re-assigning to hal-info

Hew (hew) wrote :

The E100 in MTP mode is displayed like this: ID 4102:1141 iRiver, Ltd.

Remember also that it supports flac format. It would be great to see rhythmbox just transfer my ogg vorbis and flac files as is, rather than converting them all to mp3.

Changed in hal-info:
importance: Undecided → Medium
status: New → Confirmed
Martin Pitt (pitti) wrote :

Committed upstream, with the addition of flac.

Changed in hal-info:
assignee: nobody → pitti
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20081001+git20081007-0ubuntu1

---------------
hal-info (20081001+git20081007-0ubuntu1) intrepid; urgency=low

  * New git snapshot, with all the currently reported modem and music player
    FDIs from Launchpad committed. (LP: #246741, #261685, #267227, #267727,
    #278458, #278660, #279005, #279182)
  * Drop patches 03_dell_studio.patch and 10-samsung-Q1-keymap.patch,
    committed upstream.

 -- Martin Pitt <email address hidden> Tue, 07 Oct 2008 21:47:56 +0200

Changed in hal-info:
status: Fix Committed → Fix Released
gmcd (gmcd) wrote :

Hello, I'm experiencing this bug again since karmic. It's same in Lucid Beta 2.
Ubuntu won't mount iRivier E100 internal or external memory automatically. However, mounting by:
#mount -t vfat /dev/iriver_device /media/mount_point
is successful.

Current firmware on my iriver: 1.16
Thanks for help

Hew (hew) wrote :

You are experiencing a different bug, please file a separate report for your issue.

My E100 is automatically mounting just fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers