configure ThinkPad trackpoint scrolling on installation

Bug #251408 reported by Mark on 2008-07-24
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

After a fresh install (Kubuntu Hardy 8.04.1) the trackpoint of my thinkpad is never configured correctly. Correctly meaning the middle mouse button of the trackpoint can not be used for scrolling. On the page
http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint
it is described how to do this by adding a few lines in xorg.conf:
       Option "EmulateWheel" "on"
       Option "EmulateWheelButton" "2"
       Option "YAxisMapping" "4 5"
       Option "XAxisMapping" "6 7"
Since it seems like the trackpoint is recognised anyway during installation, it should not be such an act to do this automaticly.
Additionaly it would be great if the press-to-select-functionality (also describe on the page) would be also enabled.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xorg.

Elias K Gardner (zorkerz) wrote :

I can confirm this bug it has been around for a ling time, it is still present in intrepid. It has stepped up in importance for me because they are moving away from the xorg.conf file as much as possible with intrepid. I don't know how to properly get someones attention for this.

Changed in xorg:
status: New → Confirmed
Ryan Waldroop (ryan.waldroop) wrote :

http://psung.blogspot.com/2008/09/scrolling-with-thinkpads-trackpoint-in.html

This page works like a charm for me with an IBM T41 running a fresh install of the beta, downloaded on October 2nd. So far I can't tell a difference between the old xorg.conf hack and this.

Mark (mark-wege) wrote :

But you still have to change something manually?
Would be great if developers would fix this. Does not sound like it would be a big problem.
BTW: May be it is necessary to associate this bugreport with a different package now. Does anybody know which one and is able to do this?

Timo Aaltonen (tjaalton) wrote :

We won't be adding hacks to the xorg.conf. In the future you can configure stuff on the fly, or use some configuration GUI.

Changed in xorg:
status: Confirmed → Won't Fix
Luka Renko (lure) wrote :

I am opening the task on hal-info package instead: I think it would be sensible to have ThinkPad's TrackPoint behaving as before - middle-button scrolling is widely used by ThinkPad users.

I think the proposed FDI file makes a lot of sense and according to the blog post, it has many positive feedback.

Proposed FDI file:

<match key="info.product" string="TPPS/2 IBM TrackPoint">
 <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
 <merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
 <merge key="input.x11_options.XAxisMapping" type="string">6 7</merge>
 <merge key="input.x11_options.YAxisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.ZAxisMapping" type="string">4 5</merge>
 <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
</match>

Mark (mark-wege) wrote :

the middle Button kann have press-to-select and scrolling at the same time, so it would be cool, if you provide both (the first may be as an option).

David Jaša (dejv) wrote :

Add my vote for this bug. It would be very nice to include this, as now, with hal-configured hot-plugging, this configuration doesn't affect any other mice any more. My configuration for trackpoint is attached at this post:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/282387/comments/77

And "Importance" of this bug could be set to "Feature request" if nothing...

Mark (mark-wege) wrote :

Is this your config-file any different from the one at http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint ?
Does it handle press-to-select? Or do you know how to do this?

Luka Renko (lure) wrote :

I have requested inclusion of fdi file to hal-info - will see what upstream thinks about this:
http://lists.freedesktop.org/archives/hal/2009-March/013095.html

David Jaša (dejv) wrote :

Mark: It's essentially the same config and doesn't handle press-to-select. It also works for me with simple:
echo 1 > /sys/devices/platform/i8042/serio1/serio2/press_to_select
as described on ThinkWiki. I've never used it before, simply because I was happy with normal buttons. ;)

Mark (mark-wege) wrote :

I have tested Jaunty beta. It is still not recognised on installation. I have seen you asked upstream to change something, but can Ubuntu itself fix it until this is done?

Mark (mark-wege) wrote :

The correct syntax for jaunty to enable press to select is
echo -n 1| sudo tee /sys/devices/platform/i8042/serio1/press_to_select
Unfortunatly this is does not seem to be permanent.

dfoerster (dfoerster) wrote :

Scrolling with the middle mouse button is still not working in the 9.10 stable release. This is pretty annoying and clearly a bug in my opinion. Any Thinkpad user will expect scrolling with the trackpoint to just work.

Well, apparently, there is a package that allows you easy configuration (see http://packages.ubuntu.com/gpointing-device-settings) so I don't think it's an issue.

Also, I don't see it as a clear bug. I don't have that scrolling mechanism turned on as I use and like to use my middle button as exactly that: a middle button.

I confirm this bug because it affects multiple users.

Changed in hal-info (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers