[Hardy] Thinkpad X31 (ATI Radeon M6) suspend backlight on

Bug #199059 reported by marcogoni on 2008-03-06
40
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Undecided
Martin Pitt
Hardy
Undecided
Martin Pitt
Intrepid
Undecided
Martin Pitt
pm-utils (Ubuntu)
Undecided
Martin Pitt
Hardy
Undecided
Unassigned
Intrepid
Undecided
Martin Pitt

Bug Description

When suspending in Hardy and latest kernel 2.6.24-11-generic the backlight turns off then on and stays on consuming a lot of power. So suspend is pointless. This happens on a Thinkpad X31 with ATI Radeon M6 and this is a regression from Gutsy in which suspend turned correctly off the light.

marco

Related branches

marcogoni (cogoni) wrote :

Hi, I solved the problem. Since my X31 is a 2673 model, the HAL script did not recognize the right procedure for suspending to ram. I don't know what to do now to fix the bug, please can someone explain me the standard procedure? The file to be modified is this one: /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi

marcogoni (cogoni) wrote :

I attach the modified version of the hal script.

Changed in hal:
assignee: nobody → cogoni
marcogoni (cogoni) wrote :

Hi, I created the debdiff package with the modification.
You'll find it attached here. Please let me know if I did everything correctly!

Thanks,
marco

Changed in hal:
assignee: cogoni → martin-pitt
assignee: martin-pitt → pitti
status: Fix Committed → In Progress
marcogoni (cogoni) wrote :

Hi, is anybody seeing this?
Please let me know!

Changed in hal-info:
status: In Progress → Confirmed

Yes, I am seeing the problem. I just took the dive and brought my X31 from gutsy up to current hardy, and now the backlight misbehaves on me. It looks like something pretty low-level - the suspend scripts turn it off, but something about going into sleep mode flips it back on at the last minute.

Anything I can do to help track this down?

Martin Pitt (pitti) wrote :

Thanks! I'll upload it soon, and forward it to upstream.

Changed in hal-info:
status: Confirmed → In Progress
marcogoni (cogoni) wrote :

Great Martin! Thanks for your work.

Martin Pitt (pitti) on 2008-04-02
Changed in hal-info:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20080317+git20080318-1ubuntu2

---------------
hal-info (20080317+git20080318-1ubuntu2) hardy; urgency=low

  * Add debian/patches/03_sony_vaio_VGN-TZ16_keys.patch: Fix Fn keys for
    Sony Vaio VGN-TZ16* models. (LP: #198208)
  * Add debian/patches/04_thinkpad_x31_suspend_quirks.patch: Suspend quirk for
    Thinkpad X31 (LP: #199059)
  * Add debian/patches/05_k320i.patch: Music player FDI info for the Sony
    Ericsson K320i. (LP: #199149)

 -- Martin Pitt <email address hidden> Wed, 02 Apr 2008 16:36:30 +0200

Changed in hal-info:
status: Fix Committed → Fix Released

I hate to complain, but I have hal-info 20080317+git20080318-1ubuntu2 on my X31 now, and the backlight still stays on when I suspend the system. The problem is *not* fixed for me... Is there anything I can do to help track this down?

This is with the 2.6.24-14-generic kernel, FWIW.

Martin Pitt (pitti) wrote :

Jonathan, can you please do

  lshal > hal.txt

and attach hal.txt here? Maybe your system has yet another product ID?

OK, here's the hal.txt file. Thanks for looking at it!

Martin Pitt (pitti) wrote :

Jonathan,

thanks, it's as I thought: system.hardware.product = '28844WU' (string)

Can you please try the following:

  sudo gedit /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi

and change line 36 from

        <match key="system.hardware.product" prefix="2672;2673">

to

      <match key="system.hardware.product" prefix="2672;2673;28844">

? After that, please reboot your machine (just to be 100% sure that it gets picked up) and try to suspend. Does it work?

No joy. Same behavior as before: the backlight does indeed go off, but comes back on at the very last moment as the machine suspends.

  • unnamed Edit (1.3 KiB, text/html; charset=ISO-8859-1)

hi, I know what's the problem. for some reason my patch is different from
the last deb...
instead of prefix it should be prefix_outof... this is what I mean:

- <match key="system.hardware.product" prefix="2672">
+ <match key="system.hardware.product" prefix_outof="2672;2673">

of course leave your specific model 28844 if needed...
(never seen a thinkpad with a 5 digit prefix)
hope it solves your problem!
marco

On Fri, Apr 4, 2008 at 4:03 PM, Jonathan Corbet <email address hidden>
wrote:

> No joy. Same behavior as before: the backlight does indeed go off, but
> comes back on at the very last moment as the machine suspends.
>
> --
> [Hardy] Thinkpad X31 (ATI Radeon M6) suspend backlight on
> https://bugs.launchpad.net/bugs/199059
> You received this bug notification because you are a direct subscriber
> of the bug.
>

OK, the prefix_outof change fixes the problem for me - but I *do* have to leave the 28844 model number in there too or I get the same results as before. With both changes, I once again have working suspend and resume.

Thanks for the help! I really should figure out this hal thing one of these days...user space can be so confusing...

Martin Pitt (pitti) wrote :

Argh, my bad; of course it needs to be prefix_outof.

Martin Pitt (pitti) on 2008-04-04
Changed in hal-info:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20080317+git20080318-1ubuntu3

---------------
hal-info (20080317+git20080318-1ubuntu3) hardy; urgency=low

  * debian/patches/04_thinkpad_x31_suspend_quirks.patch: Use prefix_outof to
    make patch work at all, and also add product number 28844.
    (LP: #199059)

 -- Martin Pitt <email address hidden> Fri, 04 Apr 2008 18:22:23 +0200

Changed in hal-info:
status: Fix Committed → Fix Released

Hi,

I'd just like to say that this bug affects my Thinkpad X32, and is not fixed. Attached is the output from lshal.

Changed in hal-info:
status: Fix Released → Confirmed
Nick Steeves (nick-0) wrote :

installed the latest updates this week, the backlight still remains on. "xset dpms force off" works fine, as does "sudo radeontool light off".

Changed in hal-info:
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

Indeed your lshal does not show the quirk, although the FDI should match. Can you please try doing

  sudo rm /var/cache/hald/fdi-cache
  sudo /etc/init.d/hal restart

and create and attach hal.txt again?

Nick Steeves (nick-0) wrote :

Here's the new hal.txt. I'm not sure if they're relevant to this bug, but I noticed a few errors in it:

L766 "ThinkPad R50e"
L2329 "ThinkPad T41"

I'm not sure if a quirk-work-arround for the R503e or the T41 (or some other laptop?) might be contributing to this... Is there any way I could temporarily remove all quirk-work-arrounds, as a kind of base-line test? Dapper through Feisty did not trigger this backlight issue.

Martin Pitt (pitti) wrote :

Ah, now hal does show the quirks:

    power_management.quirk.radeon_off = true (bool)
    power_management.quirk.s3_bios = true (bool)
    power_management.quirk.s3_mode = true (bool)

Does suspend work properly now with the backlight?

The other bug is of course the obsolete FDI cache. However, there are several similar bug reports against hal already, so that is already tracked.

As for the "base-line" test: you can do

  sudo dpkg -P --force-depends hal-info

then restart hal. After you are done, fix your system again with

  sudo apt-get install hal-info.

Nick Steeves (nick-0) wrote :

After fdi-cache is removed, suspend does not work properly (same behaviour; the backlight turns off, then back on, and stays on).

Without hal-info, Fn-F4 unsurprisingly does not work, but suspending from the System -> Quit menu produces the same behaviour with or without hal-info. After re-installing hal-info, I checked to see if suspending from the menu was the same as Fn-F4, and it was. The backlight turns off, then turns back on.

What else can I do to help? I've attached hal daemon verbose syslog output.

Hi,

I filed a bug in a totally unrelated package (since I don't really know how suspend/resume works these days), but it turns out that I had this same problem, because I have .... YET ANOTHER wacky X31 model number! Mine is:

  system.hardware.product = '28854WU' (string)

I changed the appropriate line in /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi to read:

      <match key="system.hardware.product" prefix_outof="2672;2673;28844;28854">

And, after rebooting, suspend seems to work correctly.

Daniel Green (dagreen) wrote :

I just wanted to confirm dhd's fix worked for me as well. I added the appropriate model number (2884) to line 35 and now suspend works correctly.

Thanks!

I have an A31 (product ID prefix 2652) and a same problem (backlight was turning on when suspending).

Adding the dpms_supend quirk and the radeon_off quirk by changing the 20-video-quirk-pm-ibm.fdi file appropriately seems to fix the problem.

Should I be adding the two s3 quirks too?

This is also logged at bug #215111.

Nick Steeves (nick-0) wrote :

jason123,

Aha, my X32 *almost* works perfectly now! Thanks for mentioning the dpms_suspend quirk. It seems to be the key to getting the X32 to work. All of the other quirks do not seem to apply to the X32 -- it doesn't seem to matter whether L40, L42, and L44 say true or false. Now if only I could get that "Policy timeout is not valid" error to go away... Any suggestions?

Martin, perhaps I don't understand XML syntax, but when I change L49 from:

        <match key="system.hardware.version" contains="X31">
to

        <match key="system.hardware.version" contains="X31;X32">

it doesn't work, while changing it to

       <match key="system.hardware.version" contains="X32">

*does*

For reference, for people who want the background information, here is the page explaining the quirks:

http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-explain.html

Nick Steeves (nick-0) wrote :

thanks for the link.

I discovered this one, from the one you posted:
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-debug.html

"sudo pm-suspend --quirk-dpms-suspend" works the best yet. If this very basic behaviour was implemented as the HAL and GNOME default, plus a locked screen, then every would work perfectly for me...

Unfortunately there's still that "Policy timeout" error, and a bit of messy pixels at the top of the screen (red), while resuming the GNOME way, rather than this pm-suspend way. They garbled bits disappear after the gnome/xscreensaver locked screen appears, but now I know that they don't *need* to be there, because pm-suspend works perfectly

Daniel (daccle) wrote :

Hi!

My X31 has a different number, maybe you also want to add it. I added it by myself and now the backlight turns off as it should.

daniel@thrax:~$ lshal | grep "system.hardware.product"
                               system.hardware.product = '2373M1G' (string)

If you are interested in the whole output of lshal please drop me a line.

 ciao,

 Daniel

Martin Pitt (pitti) on 2008-06-03
Changed in hal-info:
status: Incomplete → In Progress
Paul (paulwired) wrote :

I am another X31 user who is experiencing this bug.

Hal gets my model number but not the X31 part:

  system.hardware.product = '2672CBU' (string)
  system.hardware.vendor = 'IBM' (string)
  system.hardware.version = 'Not Available' (string)

I had to go into /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi and comment out the line

   <match key="system.hardware.version" contains="X31">

for power_management.quirk.dpms_suspend to be set true.

Martin Pitt (pitti) wrote :

mondfischer, which set of quirks does your machine need? I. e. where did you add the 2373 model exactly? Please do "lshal > /tmp/hal.txt" and attach /tmp/hal.txt here after you got a working set of quirks. Thank you!

Martin Pitt (pitti) wrote :

I collected the various bits of information here, prepared fixes, and sent them upstream:

 * X31 model number "2885" from dhd
 * A31 model number "2652" from jason123
 * X32 additional dpms_suspend from sten

I'll ask upstream for conventions how to handle Paul's situation where the model name cannot be detected. Thank you!

Changed in hal-info:
status: In Progress → Fix Committed
Daniel (daccle) wrote :

@martin

Hi Martin!

I found it via lshal ... ;-) Wouldn't it be possible to write a little script, which patches 20-video-quirk-pm-ibm.fdi automatically? Is there any way to automate the invocation of the script at time of installation?
I will also attach my 20-video-quirk-pm-ibm.fdi which works like a charm.

 best regards,

 Daniel

Daniel (daccle) wrote :
Sune Keller (sune-keller) wrote :

Even with the quirks set correctly, if /usr/lib/pm-utils/sleep.d/20video isn't updated to react on it.
Very simple patch attached.

Martin Pitt (pitti) on 2008-07-08
Changed in pm-utils:
assignee: nobody → pitti
status: New → In Progress
Nick Steeves (nick-0) wrote :

Hi,

I just did a fresh install of Hardy, ran the updates, etc. The backlight of my 2673WKS Thinkpad X32 *still* stays on during suspend. It appears line 40:
<merge key="power_management.quirk.dpms_suspend" type="bool">true</merge>
is being skipped, because the if condition
<match key="system.hardware.version" contains="X31">
fails. Even though I have a 2673, it's not an X31...

Could you please change lines 37 and 39 to test for X32, or else and and "or" condition to the if contains "X31"... so, if system.hardware.version contains "X31" or "X32", however that is done. If an "or" is not possible, could you please and a special clause for the X32? Thanks!

Changed in hal-info:
status: Fix Committed → Incomplete
Nick Steeves (nick-0) wrote :

ahh. Thanks for the heads up YAA. Martin, do you think the updated hal-info will ever make it into Hardy?

Cheers,
Nicholas

Changed in hal-info:
status: Incomplete → Fix Committed
Martin Pitt (pitti) wrote :

Yes, it will be fixed in Hardy as well. We even have a special exception for updating hal-info in stable releases.

Changed in hal-info:
assignee: nobody → pitti
status: New → In Progress

Not release critical.

Martin Pitt (pitti) wrote :

The hal-info side is already fixed in intrepid.

Changed in hal-info:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Already fixed in pm-utils in intrepid.

Changed in pm-utils:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Sune Keller, in hardy's pm-utils the 99video script already does have the patch you sent (http://launchpadlibrarian.net/15877925/20video.patch). Therefore I assume that htis is fixed in Hardy final. If you mean something else, or the gutsy version, please give some more details. Thank you!

Changed in pm-utils:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Already fixed in hardy-update's hal-info, which has version 20080508+git20080601-0ubuntu0.8.04.

Changed in hal-info:
status: In Progress → Fix Released
Damien Challet (dchallet) wrote :

an old bug, but my X21 (2662) has the same problem with release 10.10. Adding quirk-dpms-suspend also solves it. I modified 20-video-quirk-pm-ibm.quirkdb accordingly with success.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers