Ubuntu

ERROR: D_LIBRARY_PATH == /usr/lib/firefox-4.0 /usr/bin/gxine.real: symbol lookup error: /usr/bin/gxine.real: undefined symbol: JS_NewCompartmentAndGlobalObject

Reported by jon on 2011-04-29
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gxine (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: gxine

D_LIBRARY_PATH == /usr/lib/firefox-4.0
/usr/bin/gxine.real: symbol lookup error: /usr/bin/gxine.real: undefined symbol: JS_NewCompartmentAndGlobalObject

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gxine 0.5.905-4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Fri Apr 29 02:38:30 2011
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gxine
UpgradeStatus: Upgraded to natty on 2011-04-28 (0 days ago)

jon (snake4756) wrote :
Reinhard Tartler (siretart) wrote :

I can confirm this problem

Changed in gxine (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Micah Gersten (micahg) wrote :

Sorry, gxine not starting isn't critical, maybe High. This probably needs more mozjs porting. It should actually be switched to mozjs185.

Changed in gxine (Ubuntu):
importance: Critical → High
Changed in gxine (Ubuntu Natty):
importance: Undecided → High
status: New → Triaged
tags: added: regression-release
Changed in gxine (Ubuntu Natty):
milestone: none → natty-updates
Micah Gersten (micahg) wrote :

Also, this shouldn't have firefox-4.0 in its library path either.

adam jvok (ajvok1) wrote :

Apparently this is a duplicate of 768652.
A workaround for that problem is to:
export LD_LIBRARY_PATH=/usr/lib/xulrunner-2.0
before running gxine.

omega13a (omega13a) wrote :

That workaround didn't work for me. All it did was give me a different error which I've attached to this message.

Changed in gxine (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → oneiric-alpha-2
Chris Coulson (chrisccoulson) wrote :

This isn't something the desktop team looks after. In any case, this is just because the snippet in /usr/bin/gxine skips over /usr/lib/xulrunner-2.0 (and so it loads the old libmozjs from xulrunner-1.9.2 if you have it installed)

Changed in gxine (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gxine - 0.5.905-4ubuntu4

---------------
gxine (0.5.905-4ubuntu4) oneiric; urgency=low

  * Fix LP: #772835 - gxine doesn't start. Don't skip over the current
    xulrunner-2.0 libdir when looking for a libmozjs
    - update debian/gxine-wrapper.sh
 -- Chris Coulson <email address hidden> Thu, 09 Jun 2011 23:18:54 +0100

Changed in gxine (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Chris Coulson (chrisccoulson) wrote :

I've uploaded this and bug 797159 to natty-proposed

Chris Coulson (chrisccoulson) wrote :

I see this was reported 6 weeks ago. In general, it's useful to ping me about things which I've obviously broken (or at least subscribe me to the bugs), especially if I'm not subscribed to all of the bugs for a particular application. I could have had this fixed weeks ago :)

Accepted gxine into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gxine (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
dino99 (9d9) wrote :
Changed in gxine (Ubuntu Natty):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers