[GUTSY] gxine cannot find libmozjs.so

Bug #130218 reported by Christophe Dumez
40
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gxine (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gxine

When launching gxine in a term, I noticed that it refused to launch before of a missing libmozjs.so.

So I typed : aptitude search libmozjs and I found: libmozjs0d. This lib wasn't installed (missing dependency) so I installed it manually. But this didn't fix the problem because the .so file in libmozjs0d is named libmozjs.so.0d.

So I did:
ln -s /usr/lib/libmozjs.so.0d /usr/lib/libmozjs.so

and gxine is now running again.

Could someone fix this please?

Revision history for this message
litemotiv (nospam-capstone) wrote :

still reproducable on xubuntu gutsy daily, gxine won't launch from menu or console

Revision history for this message
David Andersson (l-david-andersson) wrote :

reproduced: without an argument, and with various media files as argument, and with "--version" as argument.

$ gxine
gxine: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

Using xubuntu 7.10 tribe 4, updated via synaptic ca 2007-08-19 01:12 default repositories, downloaded from Server for Sweden.

Yaron Tausky (yaront)
Changed in gxine:
status: New → Confirmed
Revision history for this message
Jelle de Jong (jelledejong) wrote :

I can confirm this.

Revision history for this message
Patrice Vetsel (vetsel-patrice) wrote :

confirmed under Tribe5
Set to High because gxine is simply unusable

Changed in gxine:
importance: Undecided → High
Revision history for this message
Phil Bull (philbull) wrote :

I can also confirm this issue. You can work around it by typing the following in a Terminal:

export LD_LIBRARY_PATH=/usr/lib/firefox && gxine

Revision history for this message
Dna222 (dna222) wrote :

I confirm this problem

I resolved it with a symbolic link:

----
 ln -s /usr/lib/firefox/libmozjs.so /usr/lib/libmozjs.so
---

Revision history for this message
caylus (adrien-dessemond) wrote : Re: [Bug 130218] Re: [GUTSY] gxine cannot find libmozjs.so

A funny stuff is that many firefox plugins are deployed in
/usr/lib/mozilla/plugins. A much more clean approach would have been to
put them in a directory like /usr/lib/mozilla-firefox/plugins and create a
symlink named 'plugins' in /usr/lib/firefox that points to this "shared"
directory.

On Tue, September 4, 2007 11:03 am, Dna222 wrote:
> I confirm this problem
>
> I resolved it with a symbolic link:
>
> ----
> ln -s /usr/lib/firefox/libmozjs.so /usr/lib/libmozjs.so
> ---
>

Revision history for this message
Darren Salt (dsalt) wrote :

This appears to me to be a firefox-dev bug - gxine's build-deps are correct.

What I think is needed:
(a) symlinks from /usr/lib to /usr/lib/firefox for the shared libs, and
(b) appropriate use of dpkg-divert in libmozjs* etc.

Ideally, gxine wouldn't build-dep on firefox-dev.

Revision history for this message
Sebastian Kapfer (caci) wrote :

Fixed in gutsy release

Changed in gxine:
status: Confirmed → Fix Released
Revision history for this message
hpis2cool (hpis2cool) wrote :

Also in Feisty on a Thinkpad T30. The instructions to fix the bug worked for me, thankfully. Quick and easy.

BavarianPH (bavarianph)
description: updated
Revision history for this message
Harald Korneliussen (vintermann) wrote :

Seems to be a regression here, I got this error after upgrading to Lucid Lynx.

Revision history for this message
allankelly (allankelly) wrote :

I have this in 10.04 LTS, for gxine:

akelly@big-blue:~$ gxine
gxine: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

The fix in the posts above doesn't work because:

akelly@big-blue:~$ find /usr/lib -name "libmozjs*"
/usr/lib/firefox-3.6.3/libmozjs.so
/usr/lib/xulrunner-1.9.2.3/libmozjs.so

Bizzarrely (to me) /usr/lib/firefox is a real directory, not a symlink to the current version. Hmm. So it seems I need to use a firefox-version-specific-fix for gxine. Which is rubbish, obviously.

So, here's a shellscript I use to launch gxine (I've called it gxine_hack.sh). Also attached.

Cheers, al.

--
gxine_hack.sh 20100502
--

#! /bin/sh
# gxine_hack.sh by allankelly AT gmail DOT com
# 2010-05-02
# Under Ubuntu 10.04 LTS, gxine install fails to run due to dependency on
# Firefox library libmozjs.so. This library is installed under version-specific
# Firefox dir under /usr/lib. So, code below gets the highest numeric
# /usr/lib/firefox-* directory and appends it to LD_LIBRARY_PATH, then runs
# gxine. This should continue to work through Firefox upgrades.
for DIR in `ls -d /usr/lib/firefox-* | grep -v addons | sort -n`
do
    FF_LIB_DIR=$DIR
done
if [ -z $LD_LIBRARY_PATH ]
then
    export LD_LIBRARY_PATH=/usr/lib/firefox && gxine
else
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/firefox && gxine
fi

Revision history for this message
allankelly (allankelly) wrote :

Oh, damn sorry that's wrong! Too hasty.

THIS is the script I use. Sorry for the previous post, it should be edited ... but I can't do that it seems.

MODS: Could you delete the solution above & indicate this is the working work-around please.

Cheers, al.

--

gxine_hack.sh Version 1.1

--

#! /bin/sh
# gxine_hack.sh by allankelly AT gmail DOT com
# 2010-05-02 v.1.1
# Under Ubuntu 10.04 LTS, gxine install fails to run due to dependency on
# Firefox library libmozjs.so. This library is installed under version-specific
# Firefox dir under /usr/lib. So, code below gets the highest numeric
# /usr/lib/firefox-* directory and appends it to LD_LIBRARY_PATH, then runs
# gxine. This should continue to work through Firefox upgrades.
for DIR in `ls -d /usr/lib/firefox-* | grep -v addons | sort -n`
do
    FF_LIB_DIR=$DIR
done
if [ -z $LD_LIBRARY_PATH ]
then
    export LD_LIBRARY_PATH=$FF_LIB_DIR
else
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$FF_LIB_DIR
fi
echo "LD_LIBRARY_PATH == $LD_LIBRARY_PATH"
gxine

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers