Ubuntu

[karmic] unsorted country list

Reported by Oliver Sauder on 2007-12-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gworldclock (Debian)
New
Undecided
Unassigned
gworldclock (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gworldclock

gworldclock gets the country list (Add Timezone) from /usr/share/zoneinfo/iso3166.tab. This file is ordered by country-codes and not by countries. Therefore the country list in gworldclock is ordered by country-codes too even though it shows you only the country names.
This order makes it difficult to find the right country.
e. g. You choose continent Asia and want to add Cambodia, which appears in list close to Korea instead of close to China.

I've developed a patch which orders the country list. You'll find this patch against version 1.4.4-6 attached.

Related branches

Oliver Sauder (sao) wrote :
TheHobbit (the-hobbit) on 2009-04-09
Changed in gworldclock (Ubuntu):
status: New → Confirmed
TheHobbit (the-hobbit) wrote :

Attached is the debdiff against current jaunty package.

The original patch posted by Oliver was a debdiff, the problem is that sponsors wheren't subscribed to the bug so nobody saw the patch, apparently.

As a rule, the relevant ubuntu-(main|universe)-sponsors group should be subscribed to the bug whenever a patch is proposed.

TheHobbit (the-hobbit) wrote :

Attached is the debdiff against current jaunty package.

The original patch posted by Oliver was a debdiff, the problem is that sponsors wheren't subscribed to the bug so nobody saw the patch, apparently.

As a rule, the relevant ubuntu-(main|universe)-sponsors group should be subscribed to the bug whenever a patch is proposed.

TheHobbit (the-hobbit) wrote :

sorry for the duplicate entry.....

Changed in gworldclock (Ubuntu):
importance: Undecided → Low
TheHobbit (the-hobbit) wrote :

Discussion on #ubuntu-bugs propted me that the previous debdiff included unwanted changes, thus here is the right one....

Iain Lane (laney) wrote :

Hi,

Thanks for your work here. I think that it's too late to include this change in Jaunty now. It'd be helpful if you could forward it to the upstream maintainers and to Debian so that we get it automatically. See https://wiki.ubuntu.com/Debian/Bugs for more information. Once this is done we can look into sponsoring the change into Karmic.

Please comment or link the bugs here when done :)

Iain Lane (laney) on 2009-04-16
summary: - unsorted country list
+ [karmic] unsorted country list
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gworldclock - 1.4.4-7ubuntu1

---------------
gworldclock (1.4.4-7ubuntu1) karmic; urgency=low

  * Sort countries by name (LP: #176862)

 -- Leo Cacciari (TheHobbit) <email address hidden> Thu, 09 Apr 2009 15:26:23 +0200

Changed in gworldclock (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers