unity-gwibber-daemon crashed with SIGABRT in g_assertion_message()

Bug #959068 reported by Sameer Morar on 2012-03-19
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

This crash occurred when logging into the unity desktop session.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-gwibber 3.3.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Mon Mar 19 17:52:18 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/gwibber/unity-gwibber-daemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: /usr/lib/gwibber/unity-gwibber-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
Signal: 6
SourcePackage: gwibber
StacktraceTop:
 g_assertion_message (domain=<optimised out>, file=<optimised out>, line=<optimised out>, func=0x7ff9ebb43aa0 "gee_hash_map_node_iterator_next", message=0x30a1630 "assertion failed: (_tmp0_ == _tmp2_)") at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1860
 g_assertion_message_expr (domain=0x0, file=0x7ff9ebb43449 "hashmap.c", line=2621, func=0x7ff9ebb43aa0 "gee_hash_map_node_iterator_next", expr=<optimised out>) at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1871
 ?? () from /usr/lib/x86_64-linux-gnu/libgee.so.2
 ?? () from /usr/lib/libgwibber.so.2
 g_closure_invoke (closure=0x21afc20, return_value=0x0, n_param_values=2, param_values=0x2ad4400, invocation_hint=<optimised out>) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:777
Title: unity-gwibber-daemon crashed with SIGABRT in g_assertion_message()
UpgradeStatus: Upgraded to precise on 2012-01-15 (64 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Sameer Morar (smorar) wrote :
visibility: private → public

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7ff9ebb43aa0 "gee_hash_map_node_iterator_next", message=0x30a1630 "assertion failed: (_tmp0_ == _tmp2_)") at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1860
 g_assertion_message_expr (domain=0x0, file=0x7ff9ebb43449 "hashmap.c", line=2621, func=0x7ff9ebb43aa0 "gee_hash_map_node_iterator_next", expr=<optimized out>) at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1871
 gee_hash_map_node_iterator_next (self=<optimized out>) at hashmap.c:2621
 gee_hash_map_node_iterator_next (self=0x2191550) at hashmap.c:2609
 ___lambda13_ (_i=0x3755750, _m=<optimized out>, self=0x215ecf0) at /storage/1/src/gwibber/trunk/libgwibber/streams.vala:216

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Steve (kpubspotter) wrote :

Finding the problem in i386 architecture.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.0-0ubuntu2

---------------
gwibber (3.4.0-0ubuntu2) precise; urgency=low

  * debian/patches/lp_959068.patch
    - work around a bug in libgee which causes the size of a HashMap to
      change if you call unset while iterating it, which invalidates
      the iterator (LP: #959068)
 -- Ken VanDine <email address hidden> Wed, 04 Apr 2012 17:04:37 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers