gwibber-service crashed with URLError in do_open(): <urlopen error [Errno 110] Connection timed out>

Bug #946049 reported by Aspersieman on 2012-03-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Medium
David Klasinc
gwibber (Ubuntu)
Low
Unassigned

Bug Description

I'm not sure exactly what happened, but I think this happened when I resumed my notebook when I opened the lid and it was trying to connect to the network. We had been having some issues with our wifi recently so that might be part of the problem.

More info:
 * OS: Ubuntu 12.04 fully updated as of today
 * Notebook: Acer Aspire 4750G

How to reproduce:
 * Close lid of notebook
 * Wait for it to suspend by closing the lid
 * Open lid and while network manager is trying to connect to the wifi network receive the above error.

I hope this bare bug helps - I'll try to reproduce it again to get more information.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gwibber-service 3.3.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Sat Mar 3 23:10:48 2012
ExecutablePath: /usr/bin/gwibber-service
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with URLError in do_open(): <urlopen error [Errno 110] Connection timed out>
UpgradeStatus: Upgraded to precise on 2012-03-01 (2 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Aspersieman (aspersieman) wrote :
tags: removed: need-duplicate-check
Ken VanDine (ken-vandine) wrote :

We should make sure we handle these kinds of failures without crashing, it is likely a transient failure so probably wrap with a try/except.

visibility: private → public
Changed in gwibber:
assignee: nobody → David Klasinc (bigwhale)
importance: Undecided → Medium
milestone: none → 3.4
David Klasinc (bigwhale) on 2012-03-12
Changed in gwibber:
status: New → Confirmed
Bilal Shahid (s9iper1) on 2012-03-14
Changed in gwibber (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in gwibber:
status: Confirmed → Fix Committed
Bilal Shahid (s9iper1) on 2012-03-15
Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.92-0ubuntu1

---------------
gwibber (3.3.92-0ubuntu1) precise; urgency=low

  * New upstream release
    - determine if we are DST or not, and set isdst in the time struct. This
      fixes the time delta being off by an hour for DST.
    - Make sure we don't keep references to Dee.ModelIter that has been
      removed (LP: #937607)
    - Use the SHA1 hash of the avatar URL instead of simply stripping the
      slashes, to avoid the resulting filename being too long to be created
      on ecryptfs volumes. (James Tait) (LP: #845374)
    - improved error handling to UrlLib2Downloader (David Klasinc) (LP: #946049)
    - facebook: try to handle data from facebook of type=question to
      prevent empty posts in the feed
    - since gtk+ 3.3.18 scroll events are getting blocked in the Gtk.Label
      for message, so we need to add the event mask for it.
 -- Ken VanDine <email address hidden> Thu, 15 Mar 2012 17:03:40 -0400

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers