gwibber-service crashed with GError in constructor(): GIF image was truncated or incomplete.

Bug #940182 reported by Vmaximoff on 2012-02-24
120
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Gwibber
Low
Unassigned
gwibber (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gwibber-service 3.3.6-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Fri Feb 24 12:48:34 2012
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with GError in constructor(): GIF image was truncated or incomplete.
UpgradeStatus: Upgraded to precise on 2012-02-21 (2 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Vmaximoff (vemaximoff) wrote :
tags: removed: need-duplicate-check
Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in gwibber:
status: New → Incomplete
Changed in gwibber (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
visibility: private → public
Changed in gwibber:
status: Incomplete → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
importance: Medium → Low
Changed in gwibber:
importance: Undecided → Low
Changed in gwibber:
milestone: none → 3.4
Changed in gwibber:
status: Confirmed → Fix Committed
Changed in gwibber:
status: Fix Committed → Fix Released
Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
JG (jdogzz-g5) wrote :

Still getting this error on a fully upgraded system.

Fakrul (eirul-a) wrote :

Just got this error again after update today.

kardos zoltán (kardipapa) wrote :

"Just got this error again after update today." i'm too

daragh (daraghfi) wrote :

returning from suspend..

Richard Senior (r-senior) wrote :

Same error ... returning from screen off.

JG (jdogzz-g5) wrote :

Happened randomly to me after Gwibber retrieved updates.

Bilal Shahid (s9iper1) wrote :

thanks for your comments any body please reproduce it and file the another bug and mention that here as well. thanks we need the new trace back.

JG (jdogzz-g5) wrote :

I can't file a new bug report since it says that the problem was already reported and takes me to this page.

Bilal Shahid (s9iper1) wrote :

we need a traceback can you run it manually and get that.

Bilal Shahid (s9iper1) wrote :

attach the file by copy pasting that out put in the terminal

JG (jdogzz-g5) wrote :

But this error doesn't predictably happen. For me it can be at random times, hours or minutes after logging in.

Bilal Shahid (s9iper1) wrote :

yes its confirmed the crash occur i also experienced it as well. but it take us to this bug and than apport can not collect more info for the bug

Bilal Shahid (s9iper1) wrote :

ken i 2 times affected this after logout and than when we login than it occurs

Ken VanDine (ken-vandine) wrote :

@s9iper1: look in /var/crash for a crash file that starts with _usr_bin_gwibber-service, please just attach that.

Bilal Shahid (s9iper1) wrote :

i have emailed you and we have talked abut that.. so marking it as triaged again because you have got the traceback

Changed in gwibber:
status: Fix Released → Triaged
Changed in gwibber (Ubuntu):
status: Fix Released → Triaged
Changed in gwibber:
milestone: 3.4 → 3.4.1
Changed in gwibber:
status: Triaged → Fix Committed
Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
importance: Low → Medium
Changed in gwibber:
status: Fix Committed → Fix Released
assignee: Ken VanDine (ken-vandine) → nobody

Hello Vmaximoff, or anyone else affected,

Accepted gwibber into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

There issue has no specific steps to be triggered but the fix seems fine, no regression was reported, setting as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.1-0ubuntu1

---------------
gwibber (3.4.1-0ubuntu1) precise-proposed; urgency=low

  * New stable release
    - fallback to displaying full sender's name if the nickname is empty, even
      if show-fullname is false (LP: #985801)
    - catch GLib.GError instead of GLib.Error, fixes crasher (LP: #940182)
    - Specify /usr/bin/python in gwibber-accounts instead of relying on
      env (LP: #988385)
    - lens: use category icons that match the rest of unity. This only affects
      the unity-lens-gwibber package in universe.
  * debian/patches/*.patch
    - dropped, merged upstream
  * debian/control
    - Added depends on gir1.2-wnck-3.0, gwibber-accounts needs it (LP: #957272)
 -- Ken VanDine <email address hidden> Wed, 25 Apr 2012 16:22:20 -0400

Changed in gwibber (Ubuntu Precise):
status: Fix Committed → Fix Released
Arun (aabisht) wrote :

{lz hel me with this problem......

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers