unity-gwibber-daemon crashed with SIGSEGV in is_end()

Bug #937607 reported by Dennis van der Staal on 2012-02-21
44
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Ken VanDine
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

starting ubuntu from cold

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-gwibber 3.3.6-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Tue Feb 21 10:00:13 2012
ExecutablePath: /usr/lib/gwibber/unity-gwibber-daemon
ProcCmdline: /usr/lib/gwibber/unity-gwibber-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f040e2a749b: mov 0x18(%rdx),%rcx
 PC (0x7f040e2a749b) ok
 source "0x18(%rdx)" (0x00000058) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gwibber
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_sequence_get () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libgwibber.so.2
Title: unity-gwibber-daemon crashed with SIGSEGV in g_sequence_get()
UpgradeStatus: Upgraded to precise on 2012-02-16 (4 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers

Related branches

Dennis van der Staal (dvdstaal) wrote :
Dennis van der Staal (dvdstaal) wrote :

reboot ubuntu after update auto start gwibber in background

StacktraceTop:
 is_end (iter=0x12e5290) at /build/buildd/glib2.0-2.31.16/./glib/gsequence.c:199
 g_sequence_get (iter=0x12e5290) at /build/buildd/glib2.0-2.31.16/./glib/gsequence.c:1167
 dee_sequence_model_peek_value (self=0x8e2150, iter=0x12e5290, column=0) at dee-sequence-model.c:586
 dee_sequence_model_get_value (self=0x8e2150, iter=0x12e5290, column=0) at dee-sequence-model.c:603
 gwibber_streams_parse_message (self=<optimized out>, obj=<optimized out>, change=<optimized out>) at /storage/1/src/gwibber/trunk/libgwibber/streams.vala:697

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
summary: - unity-gwibber-daemon crashed with SIGSEGV in g_sequence_get()
+ unity-gwibber-daemon crashed with SIGSEGV in is_end()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in gwibber:
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → 3.4
status: New → Confirmed
Changed in gwibber:
status: Confirmed → Fix Committed
Bilal Shahid (s9iper1) on 2012-03-15
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Fix Committed
Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.92-0ubuntu1

---------------
gwibber (3.3.92-0ubuntu1) precise; urgency=low

  * New upstream release
    - determine if we are DST or not, and set isdst in the time struct. This
      fixes the time delta being off by an hour for DST.
    - Make sure we don't keep references to Dee.ModelIter that has been
      removed (LP: #937607)
    - Use the SHA1 hash of the avatar URL instead of simply stripping the
      slashes, to avoid the resulting filename being too long to be created
      on ecryptfs volumes. (James Tait) (LP: #845374)
    - improved error handling to UrlLib2Downloader (David Klasinc) (LP: #946049)
    - facebook: try to handle data from facebook of type=question to
      prevent empty posts in the feed
    - since gtk+ 3.3.18 scroll events are getting blocked in the Gtk.Label
      for message, so we need to add the event mask for it.
 -- Ken VanDine <email address hidden> Thu, 15 Mar 2012 17:03:40 -0400

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers