gwibber-service crashed with error in readline(): [Errno 104] Connection reset by peer

Bug #934530 reported by Tommy the MetaKnight on 2012-02-17
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
Medium
Ken VanDine
Precise
High
Ken VanDine

Bug Description

Logging in always causes this.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gwibber-service 3.3.6-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Fri Feb 17 14:52:18 2012
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with error in readline(): [Errno 104] Connection reset by peer
UpgradeStatus: Upgraded to precise on 2012-02-13 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in gwibber (Ubuntu):
importance: Undecided → Medium

This is currently the #1 crash report on errors.ubuntu.com

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04.1
status: New → Triaged
assignee: nobody → Ken VanDine (ken-vandine)
visibility: private → public
Changed in gwibber:
status: New → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.5.2-0ubuntu1

---------------
gwibber (3.5.2-0ubuntu1) quantal; urgency=low

  * New upstream release
    - New twitter icons better matching twitter's guidelines, thanks
      Mark Tully (LP: #1012408)
    - foursquare: Changed to using urls based off Foursquare user ids rather
      than 'canonicalurl' due to 'canonicalurl' being removed from
      Foursquare's API (LP: #1012231)
    - foursquare: Added support for displaying 'likes', new to Foursquare API
  * debian/patches/lp_934530.patch
    - Catch IOError when opening a url with urllib2, prevents crash for
      connection reset errors (LP: #934530)
 -- Ken VanDine <email address hidden> Thu, 14 Jun 2012 22:56:53 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Setting in "In Progress" since the fix is in the queue waiting for review by the SRU team

Changed in gwibber (Ubuntu Precise):
status: Triaged → In Progress

Hello Tommy, or anyone else affected,

Accepted gwibber into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gwibber/3.4.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gwibber (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

The new version seems to work fine, confirmed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.2-0ubuntu2

---------------
gwibber (3.4.2-0ubuntu2) precise-proposed; urgency=low

  * debian/patches/lp_1012231.patch
    - foursquare: Changed to using urls based off Foursquare user ids rather
      than 'canonicalurl' due to 'canonicalurl' being removed from
      Foursquare's API (LP: #1012231)
  * debian/patches/lp_934530.patch
    - Catch IOError when opening a url with urllib2, prevents crash for
      connection reset errors (LP: #934530)
 -- Ken VanDine <email address hidden> Wed, 27 Jun 2012 15:42:00 -0400

Changed in gwibber (Ubuntu Precise):
status: Fix Committed → Fix Released
Bilal Shahid (s9iper1) on 2012-10-17
Changed in gwibber:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers