gwibber crashed with SIGSEGV in _gtk_icon_helper_get_storage_type()

Bug #911619 reported by Christopher Kyle Horton on 2012-01-04
68
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
gwibber (Ubuntu)
High
Ken VanDine

Bug Description

I just opened Gwibber from the messaging menu and left it open for 10-20 seconds. Then the window simply closed and led to this Apport crash report window.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gwibber 3.3.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Wed Jan 4 01:13:47 2012
ExecutablePath: /usr/bin/gwibber
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
ProcCmdline: gwibber -s messages
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f76c44b4ee0: mov 0x18(%rdi),%rax
 PC (0x7f76c44b4ee0) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gwibber
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 gtk_image_clear () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 gtk_image_set_from_pixbuf () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/libgwibber-gtk.so.2
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: gwibber crashed with SIGSEGV in gtk_image_clear()
UpgradeStatus: Upgraded to precise on 2011-12-13 (21 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

StacktraceTop:
 _gtk_icon_helper_get_storage_type (self=0x0) at /build/buildd/gtk+3.0-3.3.6/./gtk/gtkiconhelper.c:482
 gtk_image_reset (image=0x1a9ded0) at /build/buildd/gtk+3.0-3.3.6/./gtk/gtkimage.c:1336
 gtk_image_clear (image=0x1a9ded0) at /build/buildd/gtk+3.0-3.3.6/./gtk/gtkimage.c:1392
 gtk_image_set_from_pixbuf (image=0x1a9ded0, pixbuf=0x2b5a0a0) at /build/buildd/gtk+3.0-3.3.6/./gtk/gtkimage.c:764
 gwibber_gtk_stream_view_tile_load_thumbnail_async_co (_data_=0x1e715c0) at /home/ken/src/gwibber/trunk/libgwibber-gtk/stream-view-tile.vala:799

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
summary: - gwibber crashed with SIGSEGV in gtk_image_clear()
+ gwibber crashed with SIGSEGV in _gtk_icon_helper_get_storage_type()
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in gwibber (Ubuntu):
importance: Medium → High
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.1-0ubuntu4

---------------
gwibber (3.3.1-0ubuntu4) precise; urgency=low

  * debian/patches/lp_863039.patch
    - Translation fixes for plurals and time (LP: #863039)
  * debian/patches/lp_911619.patch
    - Cancel async image loading on tile reset, this breaks image previews but
      fixes the crasher with gtk 3.3.6 (LP: #911619)
 -- Ken VanDine <email address hidden> Thu, 05 Jan 2012 16:24:22 -0500

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Bilal Shahid (s9iper1) on 2012-04-15
Changed in gwibber:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers