Gwibber failing to start, or starting very very slowly

Bug #864727 reported by Rick Spencer on 2011-10-02
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Gwibber
Critical
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine
Oneiric
High
Ken VanDine

Bug Description

Steps:
1. Choose Broadcast from the messaging menu

Result:
It never starts

Steps:
2. type "gwibber" on a cl

Result:
it doesn't start, but has the message:
Timeout was reached

Steps:
3. Try again on the cl

Result:
It starts eventually, but never displays any data

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gwibber 3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sun Oct 2 18:34:31 2011
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100329)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gwibber
UpgradeStatus: Upgraded to oneiric on 2011-09-11 (20 days ago)

Note that Gwibber Service has 2 processes running, both taking 30%-40% of a CPU core. This is on my mini 10v netbook

And a Gwibber window opened about 10 minutes later, but too a very very long time to render content.

A gwibber-service process is still running, and will probably run my battery down before I can let it complete.

Ken VanDine (ken-vandine) wrote :

Please attach a debug log for the service:

killall -9 gwibber gwibber-service
gwibber-service -d

Let it run for a few minutes then attach your log (~/.cache/gwibber/gwibber.log) to that bug.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)

Ken,

gwibber-service has stopped writing to the log file, and doesn't seem to be downloading anything, but is still taking up a CPU core in top.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed

I opened bug "Gwibber in Oneiric is completely unusable" number #876840.
The bug description was deliberately vague.
But now I made a video of what I meant for "unusable": 3 minutes of 100% CPU on an AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ × 2 to open and display twitter messages.
Please take a look.
Thanks for your work

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Critical
milestone: none → 3.2.1
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

Rick is experiencing more than one bug, the client taking ages to load is what this bug to be for. I have reproduced it finally, and fixed it in both trunk and the 3.2 branches. When I reproduced it, I was getting 47 seconds to raise the client and display the stream. With the fixes I landed today, it is down to 3 seconds. I'll do a stable release update for oneiric soon.

Changed in gwibber:
status: Confirmed → Fix Committed
Changed in gwibber (Ubuntu):
milestone: none → oneiric-updates
Changed in gwibber (Ubuntu Oneiric):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
milestone: none → oneiric-updates
status: New → Confirmed
Changed in gwibber (Ubuntu):
importance: Undecided → High
milestone: oneiric-updates → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.2.1-0ubuntu1

---------------
gwibber (3.2.1-0ubuntu1) precise; urgency=low

  * New upstream release
    - don't block the UI loading when creating the model (LP: #864727)
    - Add an index to speed up retrieving messages (LP: #864727)
    - Added profiling output
    - only disconnect valid handlers
    - lens: ensure we refresh the results when the lens becomes active, but
      only if the stream_model has changed
    - lens: don't clear the results model on an invalid search
 -- Ken VanDine <email address hidden> Mon, 24 Oct 2011 11:39:56 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Ken VanDine (ken-vandine) wrote :

Steps to validate the fix:

 *) after upgrading, logout/login or run "killall gwibber-service gwibber"
 *) launch gwibber

desired results: You should see the gwibber window open in a reasonable amount of time. I my testing it was generally a few seconds. For the sake of validating the bug, lets say up to 10 seconds. When the window opens, you should see the data that was previously displayed which will get refreshed with more current data.

Changed in gwibber:
status: Fix Committed → Fix Released

Hello Rick, or anyone else affected,

Accepted gwibber into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Ken VanDine (ken-vandine) wrote :

@michele-michielin: can you please validate this fix? Rick has multiple bugs, so you would be the best verifier.

Hello,
I upgraded the package yesterday and the "slow startup bug" has disappeared:
now it takes about 4/5 seconds to load and display all my twitter messages.

For the moment I did not notice any other bug.

I'll post a video of new startup time as soon as possible.

This is the power of the community

Thanks for your work

2011/10/26 Ken VanDine <email address hidden>

> @michele-michielin: can you please validate this fix? Rick has multiple
> bugs, so you would be the best verifier.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/864727
>
> Title:
> Gwibber failing to start, or starting very very slowly
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/864727/+subscriptions
>

Martin Pitt (pitti) on 2011-10-27
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.2.1-0ubuntu1.2

---------------
gwibber (3.2.1-0ubuntu1.2) oneiric-proposed; urgency=low

  * debian/patches/lp_861903.patch
    - Revert fix for bug 812039 which caused a loop which drives CPU usage up
      when the entry is being displayed. (LP: #861903)

gwibber (3.2.1-0ubuntu1.1) oneiric-proposed; urgency=low

  * New upstream release
    - don't block the UI loading when creating the model (LP: #864727)
    - Add an index to speed up retrieving messages (LP: #864727)
    - Added profiling output
    - only disconnect valid handlers
    - lens: ensure we refresh the results when the lens becomes active, but
      only if the stream_model has changed
    - lens: don't clear the results model on an invalid search
 -- Ken VanDine <email address hidden> Wed, 26 Oct 2011 12:07:31 -0400

Changed in gwibber (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers