gwibber-service crashed with IOError in get_avatar_path(): [Errno 5] Input/output error: u'/home/nick/.cache/gwibber/avatars/https:graph.facebook.com100000124833624picture'

Bug #845374 reported by Nick T on 2011-09-09
154
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
Medium
Ken VanDine

Bug Description

crashed but I was not even using gwibber. Just booted up the computer.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gwibber-service 3.1.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Thu Sep 8 21:56:04 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with IOError in get_avatar_path(): [Errno 5] Input/output error: u'/home/nick/.cache/gwibber/avatars/https:graph.facebook.com100000124833624picture'
UpgradeStatus: Upgraded to oneiric on 2011-09-09 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Nick T (ndiggity) wrote :
tags: removed: need-duplicate-check
Changed in gwibber (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

Marking high since I work up to 3 of these and this will be a presumed issue for upgraders to beta 2.

Changed in gwibber (Ubuntu):
importance: Undecided → High
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
visibility: private → public

My error that apport marked as a duplicate of this is complaining that the file name is too long. This isn't the first time I've seen that error. I was copying over some ogg files I created a few years ago onto my Oneiric laptop and they wouldn't copy due to the filename being too long. This must be a change somewhere that is causing problematic repercussions.

Micah Gersten (micahg) wrote :

AIUI, ecryptfs is required to trigger this bug, just subscribe to a few popular groups on identi.ca like !linux or !ubuntu and it should trigger w/in 24 hours.

Changed in gwibber:
importance: Undecided → High
milestone: none → 3.3.4
status: New → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber:
milestone: 3.3.4 → 3.3.5
Changed in gwibber (Ubuntu):
importance: High → Medium
Changed in gwibber:
milestone: 3.3.5 → 3.4
James Tait (jamestait) wrote :

I've come across this bug and had the idea of hashing the URL to create the avatar filename rather than simply replacing some characters. I've never written Vala before, but I'm willing to have a bash at patching it if that would be of interest, so we can fix this in time for 12.04.

Ken VanDine (ken-vandine) wrote :

@jamestait, that is a good idea, there are two places to change it:

get_avatar_path in gwibber/microblog/util/resources.py

and

load_avatar_async in libgwibber-gtk/stream-view-tile.vala

It would be great to get a fix for this in 12.04, thanks!

Changed in gwibber:
status: Confirmed → Fix Committed
Tim (swearingen-tim) wrote :

Latest 12.04, I get many many crashes in this on bootup.

Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.92-0ubuntu1

---------------
gwibber (3.3.92-0ubuntu1) precise; urgency=low

  * New upstream release
    - determine if we are DST or not, and set isdst in the time struct. This
      fixes the time delta being off by an hour for DST.
    - Make sure we don't keep references to Dee.ModelIter that has been
      removed (LP: #937607)
    - Use the SHA1 hash of the avatar URL instead of simply stripping the
      slashes, to avoid the resulting filename being too long to be created
      on ecryptfs volumes. (James Tait) (LP: #845374)
    - improved error handling to UrlLib2Downloader (David Klasinc) (LP: #946049)
    - facebook: try to handle data from facebook of type=question to
      prevent empty posts in the feed
    - since gtk+ 3.3.18 scroll events are getting blocked in the Gtk.Label
      for message, so we need to add the event mask for it.
 -- Ken VanDine <email address hidden> Thu, 15 Mar 2012 17:03:40 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Benedikt (benedikt-klotz) wrote :

In the last two days I had crashs by Gwibber. Apport says that it is this Bug! Are you sure that this Bug is Fix Released?!?

Bilal Shahid (s9iper1) wrote :

thats fixed released,,

Micah Gersten (micahg) wrote :

You have to restart gwibber after the update. I was having the same issue.

Benedikt (benedikt-klotz) wrote :

Thanks Micah for the tip!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers