"Liked post from " cannot be translated to Dutch

Bug #833807 reported by Redmar on 2011-08-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
Low
Unassigned
gwibber (Ubuntu)
Undecided
Unassigned

Bug Description

https://translations.launchpad.net/ubuntu/oneiric/+source/gwibber/+pots/gwibber/nl/+translate?batch=25&show=all&search=Liked+post

I assume that the name of the poster will be printed after this string. In some languages however (including Dutch(nl)), the subject cannot be the last word of a sentence. This means that the above string cannot correctly be translated to all languages.

It would be great if the English string could be changed to:
"Liked post form %s", where %s would print the name of the poster.

Thankst

Thank you for your bug report. I agree with your statement, "Liked post from %s" should be used instead. Same goes for the string "Shared post from" in the same file (libgwibber-gtk/action-box.vala).

Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in gwibber:
status: New → Confirmed
Rachid (rachidbm) wrote :

Looks like the string is changed to "Liked post from".

Change status to fixed?

Redmar (redmar) wrote :

The bug is still present, I just added a translation that is valid, but not consistent or pretty. Its better to have this string translated in a crummy way then not translated at all.

Changed in gwibber:
status: Confirmed → Fix Committed
importance: Undecided → Low
milestone: none → 3.4
Redmar (redmar) wrote :

Awesome, thanks a lot for fixing this!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.1-0ubuntu1

---------------
gwibber (3.3.1-0ubuntu1) precise; urgency=low

  * New upstream release
    - Added a "debug" settings key to allow debug logging without running from
      a terminal.
    - Ensure _profile is passed a dict, if not it failed
    - Clean up indicator handling, setup the counts up front to ensure the
      ordering is consistent.
    - Only trim the padding off the entry if we are running in the client.
      This fixes the gray bar that was displayed below the poster entry
      in gwibber-poster.
    - Translation fixes for liked and shared strings (LP: #833807)
    - Added LINGUAS file to ensure the po files make it in the
      DIST (LP: #866038)
    - specify --shared-library when compiling the typelib, this fixes
      GI (LP: #893125)
  * lp_861903.patch, lp_882633.patch, and lp_884831.patch dropped, fixed
    upstream
  * debian/control
    - build depend on valac-0.14
 -- Ken VanDine <email address hidden> Mon, 21 Nov 2011 09:29:54 -0500

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers