Gwibber renders "<" as "&lt;"

Bug #825204 reported by Kai Jauch on 2011-08-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
gwibber (Ubuntu)
Low
Unassigned

Bug Description

Gwibber shows "&lt;" instead of "<" in tweets.

Attached screenshot with Gwibber rendered tweet on the left and the tweet from the twitter webinterface in Firefox on the right.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gwibber 3.1.4.1+r1119-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
CasperVersion: 1.278
Date: Fri Aug 12 13:18:55 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110812)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gwibber
UpgradeStatus: No upgrade log present (probably fresh install)

Kai Jauch (kaijauch) wrote :
Victor Vargas (kamus) on 2011-08-12
Changed in gwibber (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

https://identi.ca/notice/80776059 was another example. I &lt;3 debian just doesn't have the same effect.

Changed in gwibber:
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

I have tried to fix this, and it is driving me a bit crazy. The problem is we are using a Gtk.Label to render the message, which supports pango markup. I've tried various combinations of sanitizing and escaping data before putting it into the Gtk.Label and have had varied success. Does anyone have a good solution for this? Without making the tiles webkit :)

Changed in gwibber:
importance: Undecided → High
milestone: none → 3.2
status: Confirmed → Triaged
Changed in gwibber:
milestone: 3.2 → 3.1.5
status: Triaged → Fix Committed
Changed in gwibber:
status: Fix Committed → Triaged
Changed in gwibber:
milestone: 3.1.5 → 3.1.6
status: Triaged → Fix Committed
Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.1.5.1-0ubuntu1

---------------
gwibber (3.1.5.1-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - tile sizing fixes, getting rid of wasted space
    - revert back to python-wnck, we can't mix GIR and static
      bindings (LP: #829186)
    - use subprocess instead of Gio for handling gsettings. We can't mix GIR
      and static bindings (LP: #829186)
    - Fixes escaping of html elements properly (LP: #825204)
    - Fixed data type checks that were causing failures (LP: #830839)
    - Make sure we get time from the right json object
    - Lots of json warnings and criticals cleaned up
    - Don't crash the service if notifications fail (LP: #727568)
  * debian/control
    - Depend on python-wnck instead of gir1.2-wnck-1.0
 -- Ken VanDine <email address hidden> Tue, 23 Aug 2011 11:49:50 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers