message icons and lettering bleed through the reply box

Bug #812039 reported by Dave Morley on 2011-07-17
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)

Bug Description

See picture attached for an idea of what I see.

Basically I clicked on reply and then as you can see lettering from below bleeds through on the text entry field and icon bleed through where the send button is.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gwibber 3.1.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sun Jul 17 23:10:06 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
SourcePackage: gwibber
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in gwibber:
milestone: none → 3.2
importance: Undecided → Medium
status: New → Triaged
David Klasinc (bigwhale) wrote :

This happens because there is no concept of "z-index" in GTK and when widgets (and containers including other widgets) overlap unpredictable things can happen.

I am currently working on a solution for this.

David Klasinc (bigwhale) wrote :

I couldn't find a way on how to tame all the widgets that were bleeding and how to prevent that. The workaround fix for this is that messages move down and make room for reply box.

I attached the relevant branch.

Changed in gwibber:
milestone: 3.2 → 3.1.91
Changed in gwibber:
milestone: 3.1.91 → 3.2
status: Triaged → Fix Committed
Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.1.92-0ubuntu1

gwibber (3.1.92-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Reflect changes in updated libunity API, from Mikkel Kamstrup
      Erlandsen (LP: #844779)
    - Mark some strings for translation, thanks to Gabor Kelemen (LP: #846032)
    - Don't clean the pkgconfig files, thanks to Aaron Borden (LP: #846144)
    - nick and hashtag parsing is not unicode aware, thanks to
      Tom Callaway (LP: #812482)
    - Don't claim to handle image mimetypes
    - foursquare: actually include content from version 3 of the
      foursquare API, thanks to Teester!
    - Make sure we display valid menus for each service
    - queue a redraw after showing the entry, thanks to Neil Patel (LP: #812039)
  * debian/patches/new_libunity_API.patch
    - Dropped, merged upstream

  [Jeremy Bicha]
  * debian/control
  * debian/rules
    - Port to dh_python2
  * debian/pycompat: Dropped
 -- Ken VanDine <email address hidden> Tue, 27 Sep 2011 15:54:26 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Changed in gwibber:
milestone: 3.2 → 3.2.2
status: Fix Released → Triaged
Changed in gwibber (Ubuntu):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers