overlaped windows are not showed after clicking on item in message menu

Bug #811461 reported by Pavol Klačanský on 2011-07-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Messaging Menu
Fix Released
Low
Marco Trevisan (Treviño)
gwibber (Ubuntu)
Undecided
Unassigned
indicator-messages (Ubuntu)
Low
Marco Trevisan (Treviño)
Raring
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Open gwibber
2. Open firefox
3. gwibber should be under Firefox's window
4. click to show gwibber over envelope menu
5. unity displays gwibber gets focus, but firefox is above and gwibber is not shown

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-messages 0.4.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
Architecture: amd64
Date: Sat Jul 16 12:34:57 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANG=sk_SK.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-messages
UpgradeStatus: Upgraded to oneiric on 2011-07-16 (0 days ago)

Related branches

Bilal Akhtar (bilalakhtar) wrote :

I can reproduce this issue, but I have a slight hint that Gwibber might be responsible for this. Thunderbird/Evolution don't have the same problem with the menu.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in indicator-messages:
status: New → Confirmed
Changed in gwibber (Ubuntu):
status: Confirmed → New
Changed in indicator-messages:
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* now Is this reproducible ?

Changed in gwibber (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Low
importance: Low → Undecided

yes, I have precise and it is still there

Ken VanDine (ken-vandine) wrote :

This is really focus stealing prevention in compiz, and the way the client is getting raised. We have some hacks in some of the other apps to ensure they go to the top, but it is hard to do with gwibber because of the way the client is activated from the service. I would love to find a real fix for this issue.

Changed in indicator-messages:
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in indicator-messages (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-messages at revision 339, scheduled for release in indicator-messages, milestone Unknown

Changed in indicator-messages:
status: In Progress → Fix Committed
Changed in indicator-messages:
milestone: none → 13.04.0
Changed in compiz:
status: New → Invalid
Changed in indicator-messages (Ubuntu):
status: In Progress → Fix Released
Ted Gould (ted) on 2013-10-04
Changed in indicator-messages:
status: Fix Committed → Fix Released
Changed in indicator-messages (Ubuntu Raring):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints