gwibber-service crashed with GError in notify(): Reached stack-limit of 50

Bug #727568 reported by Antono Vasiljev on 2011-03-02
254
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gwibber

crashed after crash in yelp. Gwibber was not used at that time.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: gwibber-service 2.91.90-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Mar 2 05:16:04 2011
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with GError in notify(): Reached stack-limit of 50
UpgradeStatus: Upgraded to natty on 2011-02-25 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Antono Vasiljev (antono) wrote :
Antono Vasiljev (antono) wrote :

notify-osd stack was really full by previous undisplayed yet notifications (because of notify osd delay) . But anyway gwibber-service should not crash.

This crash has the same stack trace characteristics as bug #622812. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Victor Vargas (kamus) on 2011-03-08
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
visibility: private → public
Victor Vargas (kamus) wrote :

Antonio, are you still facing this behaviour with latest release 2.91.91?

Changed in gwibber (Ubuntu):
status: New → Incomplete
Antono Vasiljev (antono) wrote :

I havent seen this during long time. But i doubt that i reached osd notification limit (as mentioned in title) last time.

MoLE (moleonthehill) wrote :

Still happening on latest release as of 20110330.

Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
tags: added: bugpattern-needed
Changed in gwibber:
milestone: none → 3.1.6
status: New → Fix Committed
Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.1.5.1-0ubuntu1

---------------
gwibber (3.1.5.1-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - tile sizing fixes, getting rid of wasted space
    - revert back to python-wnck, we can't mix GIR and static
      bindings (LP: #829186)
    - use subprocess instead of Gio for handling gsettings. We can't mix GIR
      and static bindings (LP: #829186)
    - Fixes escaping of html elements properly (LP: #825204)
    - Fixed data type checks that were causing failures (LP: #830839)
    - Make sure we get time from the right json object
    - Lots of json warnings and criticals cleaned up
    - Don't crash the service if notifications fail (LP: #727568)
  * debian/control
    - Depend on python-wnck instead of gir1.2-wnck-1.0
 -- Ken VanDine <email address hidden> Tue, 23 Aug 2011 11:49:50 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.