Facebook authentication failure is very unclear

Bug #681940 reported by Sense Egbert Hofstede on 2010-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
gwibber (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gwibber

When Facebook authentication in Gwibber fails, a notification is shown using Notify OSD. However, the icon used for this notification is Facebook's logo, and the title of this notification is simply 'facebook'. Its body only mentions a Facebook authentication failure.

Nothing in this notification message indicates that this error happened in Gwibber. It could just as well have taken place in Empathy, or maybe even in the web browser!

The notification should be changed to convey that it is sent by Gwibber.

Also, currently when you are notified via Notify OSD of a Facebook authentication failure, the Facebook entry in the accounts dialogue still says that you were successfully authenticated to Facebook. However, this is not the case and causes even more confusion, because the user will by now most certainly not know that the authentication failure was actually in Gwibber.

The entry from ~/.cache/notify-osd.log:
[2010-11-26T22:25:38-00:00, Gwibber ] facebook
Authentication failed, please re-authorize

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gwibber 2.91.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-6.17-generic 2.6.37-rc3
Uname: Linux 2.6.37-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Nov 26 22:37:22 2010
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=nl_NL:nl:en_GB:en
 LANG=nl_NL.utf8
 SHELL=/bin/bash
RelatedPackageVersions:
 desktopcouch 0.6.9b-0ubuntu1
 gnome-keyring 2.92.92.is.2.31.91-0ubuntu5
SourcePackage: gwibber

Sense Egbert Hofstede (sense) wrote :
Kamus (kamus) wrote :

I have sent your requirement to upstream tracker for now.
PD: totally agree with you

Changed in gwibber (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better,
* can you reproduce it ?
* if so than which version are you on ?

Changed in gwibber:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers