gwibber prepends "is" to messages sent to facebook

Bug #674894 reported by E. Mark Anderson on 2010-11-13
144
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Ken VanDine
gwibber (Fedora)
Fix Released
Undecided
gwibber (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: gwibber

Ubuntu 10.10
Gwibber 2.32.2-0ubuntu1

I'm glad to see Gwibber is able to post to facebook again, but now it's prepending "is" to my messages. While this is intended behavior by the programmers, not EVERY facebook user uses that messages schema. It needs to be made into an option that can easily be toggled per message. Perhaps a check box next to the text entry field labeled "Prepend 'is' on FB", or something similar.

Related branches

Omer Akram (om26er) wrote :

now i know why my message 'test' was shown 'is test' in facebook

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Omer Akram (om26er) on 2010-11-13
description: updated
Omer Akram (om26er) wrote :
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Medium
status: New → Fix Committed
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Changed in gwibber:
milestone: none → 2.91.1
Jonas Saso (jonassaso) wrote :

There's no need to prepend is as an option since you can simple just type it. It isn't so hard typing it rather that going to preferences and enable that option and the next day disable it. Just a thought though. Thanks!

Omer Akram (om26er) wrote :

i have uploaded gwibber with the fix to gwibber-team ppa https://launchpad.net/~gwibber-team/+archive/ppa

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.91.1-0ubuntu1

---------------
gwibber (2.91.1-0ubuntu1) natty; urgency=low

  * New unstable release
    - statusnet:
      * Fixed an if statement that was causing errors to get lost in some cases
      * Enable the public stream by default, it is useful for dedicated
        status.net instances
    - facebook:
      * Ported to use the Graph API
      * Fixed rendering of "likes", and improved display of links, videos,
        photos, etc
      * Tell facebook not to prepend "is " to posts (LP: #674894)
    - dispatcher:
      * Handle python-indicate from karmic, the indicator doesn't send
        a timestamp
      * Fixed failure to notify for private messages (LP: #663377)
      * Treat strings starting with "www." as a href (LP: #324809)
    - client:
      * Merged in keyboard control from Michael Hall (LP: #621953)
      * Don't traceback older version of pygtk which didn't have gtk.InfoBar
      * added missing public.png icons, for 24x24 and 32x32
    - accounts: Show the auth button if we know there was an auth failure
 -- Ken VanDine <email address hidden> Tue, 16 Nov 2010 21:36:50 -0500

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
Michael Vogt (mvo) wrote :

The link http://bazaar.launchpad.net/~gwibber-committers/gwibber/trunk/revision/928 does not seem to be linking to the specific change?

Ken VanDine (ken-vandine) wrote :

It was included in http://bazaar.launchpad.net/~gwibber-committers/gwibber/trunk/revision/922 as part of a much bigger merge, bit the specific change was:

- result = self._get("users.setStatus", status=message, status_includes_verb=False)
+ result = self._get("me/feed", message=message, status_includes_verb=True, post=True)

Should be trivial to backport to maverick, facebook just changed the way they interpret the status_includes_verb argument.

Ken VanDine (ken-vandine) wrote :

However, I should highlight that specific change won't work with the old rest API used in 2.32.x, it would be more like:

result = self._get("users.setStatus", status=message, status_includes_verb=True)

Omer Akram (om26er) wrote :

this is what my branch did:

- result = self._get("users.setStatus", status=message, status_includes_verb=False)
+ result = self._get("users.setStatus", status=message, status_includes_verb=True)

there was a commit in gwibber trunk before the facebook plugin was ported to graph API:
 "Tell facebook not to prepend "is " to post" (now its log is lost in trunk)

i backported that. (the same what you suggested in comment#8)

Accepted gwibber into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Luca Ferretti (elle.uca) wrote :

It works :)

tags: added: verification-done
removed: verification-needed

Can someone add this bug to future gwibber stable release 2.32.3 ?

Ken VanDine (ken-vandine) wrote :

This has been fixed in the stable branch and will be included in the next stable release

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.32.2-0ubuntu2

---------------
gwibber (2.32.2-0ubuntu2) maverick-proposed; urgency=low

  * debian/patches/do_not_prepend_is.patch
    - do not prepend 'is ' on facebook status updates (LP: #674894)
 -- Omer Akram <email address hidden> Tue, 16 Nov 2010 00:14:22 +0500

Changed in gwibber (Ubuntu Maverick):
status: Fix Committed → Fix Released
Juan Simón (simonbcn) wrote :

The users of Lucid exist too. Lucid is a LTS version!!
Where is the correction of this annoying bug on Lucid?

Juan Simón (simonbcn) wrote :

What's the file I have to modify to remove this in my gwibber 2.30.3-0ubuntu1?

otakuj462 (otakuj462) wrote :

Please backport to Lucid.

Rick Pontefract (rjpontefract) wrote :

I would also like to see this backported to Lucid as it is an LTS release.

we are trying

On Wed, Jan 5, 2011 at 1:20 PM, Sazhen86 <email address hidden> wrote:

> I would also like to see this backported to Lucid as it is an LTS
> release.
>
> --
> You received this bug notification because you are subscribed to gwibber
> in ubuntu.
> https://bugs.launchpad.net/bugs/674894
>
> Title:
> gwibber prepends "is" to messages sent to facebook
>
> Status in Gwibber:
> Fix Released
> Status in “gwibber” package in Ubuntu:
> Fix Released
> Status in “gwibber” source package in Maverick:
> Fix Released
>
> Bug description:
> Binary package hint: gwibber
>
> Ubuntu 10.10
> Gwibber 2.32.2-0ubuntu1
>
> I'm glad to see Gwibber is able to post to facebook again, but now it's
> prepending "is" to my messages. While this is intended behavior by the
> programmers, not EVERY facebook user uses that messages schema. It needs to
> be made into an option that can easily be toggled per message. Perhaps a
> check box next to the text entry field labeled "Prepend 'is' on FB", or
> something similar.
>
>
>
>
>

Changed in gwibber (Ubuntu Lucid):
status: New → In Progress

Accepted gwibber into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Can anyone please give the gwibber in lucid-proposed some testing and report back? We are currently wrapping up the 10.04.2 point release, and need to verify proposed updates really soon now. Thank you!

Omer Akram (om26er) wrote :

I have verified the fix in lucid a few days ago and it works fine. it seems I forgot to mention it here :/

tags: added: verification-done
removed: verification-needed

On Wed, 2011-01-26 at 14:00 +0000, Martin Pitt wrote:
> Can anyone please give the gwibber in lucid-proposed some testing and
> report back? We are currently wrapping up the 10.04.2 point release, and
> need to verify proposed updates really soon now. Thank you!

It works for me, thanks for fixing this!

Sam Denison
<email address hidden>

Sam Denison (sam-denisons) wrote :

On Wed, 2011-01-26 at 14:32 +0000, Sam Denison wrote:
> On Wed, 2011-01-26 at 14:00 +0000, Martin Pitt wrote:
> > Can anyone please give the gwibber in lucid-proposed some testing and
> > report back? We are currently wrapping up the 10.04.2 point release, and
> > need to verify proposed updates really soon now. Thank you!
>
> It works for me, thanks for fixing this!

Sorry, I am using Ubuntu 10.10 and gwibber 2.32.2-0ubuntu .

Sam out.

Rick Pontefract (rjpontefract) wrote :

It works for me in 10.04 as well. Many thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.3-0ubuntu2

---------------
gwibber (2.30.3-0ubuntu2) lucid-proposed; urgency=low

  * debian/patches/do_not_prepend_is.patch:
    - Do not prepend 'is' in facebook status updates. (LP: #674894)
 -- Omer Akram <email address hidden> Thu, 06 Jan 2011 00:23:12 +0500

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released

Description of problem:

If I use gwibber to post a message to facebook, the message is prefixed with "is".

Version-Release number of selected component (if applicable):
gwibber-2.33.0-12.894bzr.fc14.noarch

How reproducible:

Steps to Reproduce:
1. Setup facebook account
2. Post message to facebook account
3. Look at your facebook profile

Actual results:
Message is prefixed with "is "

Expected results:
Message should appear like I typed it.

Additional info:
The problem seems to be fixed in some ubuntu ppa:
http://www.facebook.com/permalink.php?story_fbid=10150325640155515&id=2877035514

Ubuntu fixed this in their packages in this bug:
https://bugs.launchpad.net/bugs/674894

The upstream patch that fixed it was:
http://bazaar.launchpad.net/~gwibber-committers/gwibber/trunk/revision/922

*** Bug 678801 has been marked as a duplicate of this bug. ***

gwibber-2.91.92-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc13

gwibber-2.91.92-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc14

gwibber-2.91.92-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc15

Package gwibber-2.91.92-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gwibber-2.91.92-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc15
then log in and leave karma (feedback).

gwibber-2.91.92-2.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

gwibber-3.0.0.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gwibber-3.0.0.1-1.fc14

gwibber-3.0.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-3.0.0.1-1.fc15

gwibber-3.0.0.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gwibber-3.0.0.1-1.fc13

gwibber-3.0.0.1-1.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

gwibber-3.0.0.1-1.fc14 has been pushed to the Fedora 14 stable repository. If problems still persist, please make note of it in this bug report.

gwibber-3.0.0.1-1.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

Changed in gwibber (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.