No notification of Direct messages

Bug #663377 reported by Laura Czajkowski on 2010-10-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Unassigned
gwibber (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: gwibber

When you get a message via gwibber you see a notification bubble plus the name is present under the indicator under broadcast so you can see how many @messages you have received. The same is not done for a direct message. Which means unless you have gwibber open you don't notice you have a dm received.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gwibber 2.32.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Tue Oct 19 17:28:38 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
SourcePackage: gwibber

Laura Czajkowski (czajkowski) wrote :
Ken VanDine (ken-vandine) wrote :

I think I fixed this in trunk this weekend, I'll verify and look at back-porting to 2.32.x

Changed in gwibber:
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Triaged
Ken VanDine (ken-vandine) wrote :

Actually, I think this was fixed in 2.32.0.2 which is in the unapproved queue for a Maverick SRU

Victor Vargas (kamus) wrote :

Well nothing that we can do for now, just wait until backport will approved, Thanks Ken.

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in gwibber:
status: Triaged → Fix Released
milestone: none → 2.32.3
Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
Changed in gwibber:
assignee: Ken VanDine (ken-vandine) → nobody

Accepted gwibber into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.91.1-0ubuntu1

---------------
gwibber (2.91.1-0ubuntu1) natty; urgency=low

  * New unstable release
    - statusnet:
      * Fixed an if statement that was causing errors to get lost in some cases
      * Enable the public stream by default, it is useful for dedicated
        status.net instances
    - facebook:
      * Ported to use the Graph API
      * Fixed rendering of "likes", and improved display of links, videos,
        photos, etc
      * Tell facebook not to prepend "is " to posts (LP: #674894)
    - dispatcher:
      * Handle python-indicate from karmic, the indicator doesn't send
        a timestamp
      * Fixed failure to notify for private messages (LP: #663377)
      * Treat strings starting with "www." as a href (LP: #324809)
    - client:
      * Merged in keyboard control from Michael Hall (LP: #621953)
      * Don't traceback older version of pygtk which didn't have gtk.InfoBar
      * added missing public.png icons, for 24x24 and 32x32
    - accounts: Show the auth button if we know there was an auth failure
 -- Ken VanDine <email address hidden> Tue, 16 Nov 2010 21:36:50 -0500

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

i have been using gwibber 2.32.1 and then later 2.32.2 but have not found any regression neither received any regression bug reports. on the other side facebook situation have improved alot so i am marking this as verification done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.32.2-0ubuntu1

---------------
gwibber (2.32.2-0ubuntu1) maverick-proposed; urgency=low

  * Drop the responses operation from facebook, it abuses the
    allocation facebook gives us based on the DB query count (LP: #614742)
  * Fixed notifications for private messages (LP: #663377)

gwibber (2.32.1-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release (LP: #673161)
    - Backported fix for clearing multi-column streams when activated by
      the messaging indicator (LP: #643487)
    - Save window size/position when it changes, so it doesn't get moved
      unexpectedly when activated by the messaging indicator
    - Fixed dupe notifications as well as displaying dupes in the stream
    - Shouldn't display reply icon for messages from you (LP: #661330)
    - Private messages shouldn't allow public replies (LP: #661358)
    - Private messages shouldn't allow retweets (LP: #661359)
 -- Ken VanDine <email address hidden> Wed, 10 Nov 2010 23:14:44 -0500

Changed in gwibber (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers