Page down on the scroll-bar goes down more than one page

Bug #629420 reported by David Dean on 2010-09-03
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Unassigned
gwibber (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gwibber

Running gwibber in newly upgraded maverick. When I page down using the scroll bar it seems to go more than one page down and I miss out on a full page of messages that I don't see.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gwibber 2.31.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Fri Sep 3 20:56:24 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: gwibber

David Dean (ddean-ieee) wrote :
Victor Vargas (kamus) wrote :

maybe you are facing bug 625863 ?

Changed in gwibber (Ubuntu):
importance: Undecided → Low
David Dean (ddean-ieee) wrote :

This is not the same as bug 625863.

David Dean (ddean-ieee) on 2010-10-05
summary: - Page down on the scroll-bar goes down two pages
+ Page down on the scroll-bar goes down more than one page
description: updated
David Dean (ddean-ieee) wrote :

Okay, I've delved into this problem a bit more and it seems that the issue is that no matter how I resize my gwibber window, the page-down amount on the scroll bar is always the same. Only if I maximise my gwibber window does it come close to being correct for one full page of tweets (even then it is still off by one).

I've attached an image to illustrate this. Please excuse the blurring, as some of the tweets may have been private.

Omer Akram (om26er) wrote :

we might get this bug fixed in gwibber 3.0 in Natty, I believe

Changed in gwibber (Ubuntu):
status: New → Triaged
Changed in gwibber:
importance: Undecided → Medium
status: New → Confirmed
Jesse Otto (rootofjesse) wrote :

It appears to me that this is still present in Oneiric. If I make a note of the last message in the window, press PageDown, that noted message is not visible at the top of the screen, and if I use the Up directional key, there are one or two messages that were "skipped" before I can see the message I made note of. This is particularly a nuisance since I dislike scrolling the Gwibber window due to lack of smooth scrolling, and PageUp PageDown would be a nice alternative if it showed all messages.

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
assignee: Ken VanDine (ken-vandine) → nobody
milestone: none → 3.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.91-0ubuntu1

---------------
gwibber (3.3.91-0ubuntu1) precise; urgency=low

  * New upstream release
    - Fix duplicate detection by falling back to comparing html,
      link_description, image_url and video_url (LP: #933694)
    - Fixed account migration path from 2.32 (desktopcouch) to
      3.4 (sqlite) (LP: #740494)
    - gwibber-accounts crashed with TypeError in function(): Item 0: must
      be a subtype of gi.Boxed (LP: #936071)
    - Fixed position tracking so page down and page up move the
      appropriate number of tiles (LP: #629420)
    - more escaping of text that pango markup can't support
    - twitter: Use Twitter entities, improves getting hashtags, mentions,
      links, images, and videos. Thanks to Mark Tully (LP: #948092)
 -- Ken VanDine <email address hidden> Thu, 08 Mar 2012 16:51:57 -0500

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Changed in gwibber:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers