When scrolling by mouse until the last message, gwibber shows the top post

Bug #627106 reported by lipstick on 2010-08-30
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Gwibber
Low
Unassigned
gwibber (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gwibber

If I scroll the gwibber page by middle button of mouse, when i reach to the very end, it shows the top posts.

However, if I go to the very bottom via the scroll bar, there is no such a problem.

I added SSs to describe it better;

http://www.incicaps.com/?v=sosyal-1283204937.png
http://www.incicaps.com/?v=sosyal-1283204971.png
http://www.incicaps.com/?v=sosyal-1283205013.png

Related branches

quantenemitter (quantenemitter) wrote :

Dupe of #627126 ?

Ricardo Salveti (rsalveti) wrote :

Not dupe because in this case it returns to the top, and not just scroll fast.

Can also confirm that this happens with the latest Maverick package (2.31.93-0ubuntu1).

Ricardo Salveti (rsalveti) wrote :

Can also reproduce with upstream 2.31.95

summary: - gwibber scroll has a problem while scrolling by mouse
+ When scrolling by mouse until the last message, gwibber shows the top
+ post
Matt Condren (scondren13) wrote :

The problem is in gwui.MessageStream.on_viewport_scroll(). handle_scroll() is called with a value which may not be within the range of the scrollbar, and therefore the range of messages, which causes it to revert to showing the top of the page. It also causes the gap when you scroll up when at the top message. The scrollbar automatically corrects for this when it is set, but the out-of-bounds value is sent to handle_scroll(). Attached a patch which sends scrollbar.get_value() instead.

Matt Condren (scondren13) wrote :

Sorry, let me try that again.

Matt Condren (scondren13) wrote :

Baaah, one last time.

Victor Vargas (kamus) wrote :

Please could you include all the images here because external links are not working any more.

Changed in gwibber (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) on 2010-11-03
Changed in gwibber:
importance: Undecided → Low
status: New → Confirmed
Changed in gwibber (Ubuntu):
status: New → Triaged
Michael Hall (mhall119) wrote :

Calling self.scrollbar.set_value triggers an automatic call to on_scroll, which in turn calls handle_scroll, so there is no need to call handle_scroll again after calling self.scrollbar.set_value.

My branch https://code.launchpad.net/~mhall119/gwibber/keyboard-control-622677-try2/+merge/39420 already has a fix for this, by setting len(self.messages) as the upper bounds for the scroll value, and 0 for the lower bound, and removing the redundant call to handle_scroll.

Changed in gwibber:
status: Confirmed → Fix Committed
milestone: none → 2.91.1
Changed in gwibber:
status: Fix Committed → Fix Released
Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments