Gwibber notification preferences are confusing

Bug #621646 reported by Jorge Suárez de Lis on 2010-08-21
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
Undecided
Ken VanDine

Bug Description

Binary package hint: gwibber

On Gwibber, there are 2 options regarding notifications:

1: Display notifications (yes/no)
2: Only display notifications for mentions (yes/no)

Both options have the same padding and the second one won't disable if the first one is disabled. Then, what does these options mean?

Both enabled: Display only notifications for mentions
Both disabled: Display no notifications
1 enabled, 2 disabled: Display all notifications
1 disabled, 2 enabled: Display only notifications for mentions?

As you can see, there is problem here. If the option 2 is depending on option 1, it should be padded to the right and disabled if the first one is disabled. If the option 2 is independent, then the text is misleading.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gwibber 2.31.90-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-16.22-generic 2.6.35.2
Uname: Linux 2.6.35-16-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Aug 21 10:08:23 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
PackageArchitecture: all
ProcEnviron:
 LANG=es_ES.utf8
 SHELL=/bin/bash
SourcePackage: gwibber

Jorge Suárez de Lis (ys) wrote :
Jorge Suárez de Lis (ys) wrote :
description: updated
Zool (zooldevil) wrote :

Yup. He is right. If both settings aren't checked, Gwibber won't give any notifications. Thanks Jorge for giving this info. I hate to open/close Gwibber to check the messages/tweets over and over again.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Changed in gwibber:
status: New → Confirmed
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
milestone: none → 2.31.92
Andreas Nilsson (andreasn) wrote :

One thing that could be done here is to use radiobuttons instead of checkboxes.
After some discussion with Ken and Paul Cutler (doc writer) on IRC, we came up with the following suggestion:

Show notifications for:
( ) All messages
( ) Mentions and replies only
( ) Do not display notifications

Sure, the last one is a little bit backwards, but the alternative to have it say "No messages" (to make it more as part of a sane sounding sentence) is a bit confusing.

Changed in gwibber:
milestone: 2.31.92 → 2.31.93
Ken VanDine (ken-vandine) wrote :

Screenshot of proposed change

Phil Bull (philbull) wrote :

Feedback from the docs team: The proposed change looks much less confusing and we don't have any doc strings/screenshots that depend on it as far as I can tell, so making the modification should be fine.

A couple of potential issues: It might not be clear what "Mentions and replies" are to some users (different terms are used on different networks, and novices may not be aware of the concepts), so a good explanatory tooltip should be provided. Something like "Only receive notifications when someone replies to one of your messages or mentions your name" might work. Also (somewhat unrelated to this bug), the "Start service at login" label is quite technical. Perhaps changing it to something like "Start watching for new messages when I log in" would be more understandable.

Ken VanDine (ken-vandine) wrote :

Docs and translations team are OK with this change, but we need to upload it soon.

The change is mostly ready, I'll incorporate some of the feedback provided here as well.

I subscribed the release team for approval.

2010/9/12 Ken VanDine <email address hidden>

> Docs and translations team are OK with this change, but we need to
> upload it soon.
>
> The change is mostly ready, I'll incorporate some of the feedback
> provided here as well.
>
> I subscribed the release team for approval.
>
>
May I please see a ChangeLog before approving?

Ta,
Iulian

Ken VanDine (ken-vandine) wrote :

The changelog won't be very interesting, it is just a single file. I am attaching the patch, just note there will be a slight change to this patch before uploading to incorporate the suggestions to help make it even clearer. It will only be more changes to the same glade file, adding tooltips for the radio buttons.

Iulian Udrea (iulian) wrote :

Thanks Ken. Ack.

Andreas Nilsson (andreasn) wrote :

"Also (somewhat unrelated to this bug), the "Start service at login" label is quite technical. Perhaps changing it to something like "Start watching for new messages when I log in" would be more understandable."

I think this makes sense too.
Can you open that issue as a separate bug?

Changed in gwibber:
status: Confirmed → Fix Released
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ubuntu-10.10
Ken VanDine (ken-vandine) wrote :

Andreas: Please file a separate bug about the "Service start at login" setting, we'll clean that up next cycle. I would rather not try to cram to many string changes through this late now.

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Allan Day (allanday) wrote :

"Show notifications for:
( ) All messages
( ) Mentions and replies only
( ) Do not display notifications"

Is it possible to describe what 'All messages' refers to? This option is a bit pointless without that information, since a user has no idea what they are enabling/disabling.

An alternative approach would be:

"Show notifications for:
 [ ] Mentions
 [ ] Replies
 [ ] Foo
 [ ] Bar"

Admittedly, this could be too verbose, and you probably wouldn't want this level of granularity. This approach has its merits though, I think.

Feel free to ignore this if you've already considered this option. ;)

Andreas Nilsson (andreasn) wrote :

Sure!
Filed as bug 637891

Vish (vish) wrote :

Show notifications for:
( ) All messages
( ) Mentions and replies only
( ) Do not display notifications

This is a malformed sentence.. The header is Show.. while the option is Do not display , contradictory

A better way would have been:

[ ] Display notifications for
( ) All messages ( ) Mentions and replies only

The checkboxes would only be active when Display Notifications is enabled.

Vish (vish) wrote :

easier change suggested by Calum Benson
<calumb>
 Show message notifications:
()Always
()Only for mentions and replies
()Never

Vadim Rutkovsky (roignac) wrote :

I'd vote for "alternative approach" from comment #15 - this allows us to add new options later (e.g. friends):
"Show notifications for:
 [ ] Mentions
 [ ] Replies
 [ ] From all friends
 [ ] From mutual friends
 [ ] Foo
 [ ] Bar"

Jorge Suárez de Lis (ys) wrote :

Vadim, you mean comment #13, right?

I like the second approach on comment #15. I also noticed the malformed sentence, but I don't know if it's that important to form good sentences anyway.

Vadim Rutkovsky (roignac) wrote :

@Jorge: yes, you are correct.

I don't think that an option with radiobuttons is a good solution - it is not flexible enough to set notification rules, keeping in mind than other notification rules might be added in future.

However, the second approach from comment #15 (correct number :) is better than 2nd from comment #13 - user is able to turn off notification with a single click. So, a slightly modified variant (checkboxes only):

[ ] Display notifications for:
   [ ] All messages
   [ ] Mentions
   [ ] Replies
   [ ] Foo
   [ ] Bar

If "Display notifications for" is unchecked, all elements are disabled. If "All messages" are checked, all checkboxes are checked (not sure about this, though it seems pretty natural for me).

Vish (vish) wrote :

@Vadim Rutkovsky : Those options do not exist yet.. So not point in adding checkboxes foo , bar just for something in future.. :)
Lets stick to the bug and get the wording right for now.. and when the other options exits, we can probably add them later.

Vadim Rutkovsky (roignac) wrote :

Several wishlist defects were submitted - autocomplete friends (bug 247015) and message filtering (bug 395054). These defects might require notification options.
So I'd like to work out a scalable decision on notification settings, assuming that new options will be added. IMHO it is much clearer (and easier for developers) to add new checkboxes under each other (instead of forming a line).

Anyway, vox populi - vox dei, lets hear all suggestions and see results of improvised voting in the discussion for this defect.

I'm planning to make a branch of current trunk and try to implement several approaches - maybe, this will result in a PPA package.

Allan Day (allanday) wrote :

What I was pointing out is that 'All Messages' isn't clear. 'Mentions and Replies' is clearly a subset of 'All Messages', so what else is included? Does 'All Messages' = status updates + mentions + replies? Or is there something else in there? The dialog isn't clear about this.

An alternative to the existing solution might be:

"Show notifications for:
 [ ] Status updates
 [ ] Replies
 [ ] Mentions"

This communicates the available functionality more fully than the other suggestions but using the same amount of UI.

No boxes checked == no updates. :)

Vadim Rutkovsky (roignac) wrote :

As "status updates" includes mentions and replied, maybe, this item should be renamed to "other updates" and moved to the bottom of the list?

Andreas Nilsson (andreasn) wrote :

Whups, seems I created a small bike shed. :)
My intent with the radiobuttons was mainly to get rid of the behavior where one checkbox would made the other one not work.
A side effect was that we got three levels of notification noise, perhaps a bit similar to a stop light. Maybe that is a good sign.
Spit and polish would be the wording, but apart from that, maybe we want to move on to other bugs?

Scott Kitterman (kitterman) wrote :

Since this bug is fixed, at a minimum please move the discussion to a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers