Ubuntu

gwibber-service crashed with GError in __getitem__()

Reported by Rodolfo Augusto Manzoli on 2010-08-18
922
This bug affects 101 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Unassigned
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gwibber

gwibber-service crashed with GError

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gwibber-service 2.31.5-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic x86_64
Architecture: amd64
Date: Wed Aug 18 02:52:47 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gwibber-service
InstallationMedia:

InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/gwibber-service']
SourcePackage: gwibber
Title: gwibber-service crashed with GError in __getitem__()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video

tags: removed: need-duplicate-check
Kamus (kamus) on 2010-09-07
visibility: private → public
Kamus (kamus) wrote :

Have you upgraded from Lucid before this issue happens? Please can you try to reset the gconf settings of gwibber and try to reproduce this issue? for do that you should run something like "gconftool-2 --recursive-unset /apps/gwibber"

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

  On 13/09/10 16:56, Kamus wrote:
> Have you upgraded from Lucid before this issue happens?
yes
> Please can you
> try to reset the gconf settings of gwibber and try to reproduce this
> issue? for do that you should run something like "gconftool-2
> --recursive-unset /apps/gwibber"
>
i just did.
i ll report if it happens again.

Vadim Rutkovsky (roignac) wrote :

Could you please execute gconftool-2 --dump /apps/gwibber > gwibber-settings.xml and attach gwibber-settings.xml here?

tobias_t (linuxert) wrote :

gwibber settings

Vadim Rutkovsky (roignac) wrote :

@tobias_t: resetting gwibber-settings (like in #2) and setting up settings from Gwibber again should help.

Yet I'm curious - how come you have a setting called "refresh_interval"? It should be called "interval". Did you rename \ edit the setting yourself? Please, specify which gwibber version did you use before the error has occurred.

Kamus (kamus) wrote :

any news about this issue?

Gary M (garym) wrote :

This error just occurred for me on a system with current updates based on a maverick alpha-3 desktop install. A possible contributory factor was a recent install of the netbook package, with this error happening the first time I logged-in using a netbook session. Desktop sessions since that install had been ok.

Gary M (garym) wrote :

Traceback below shows problem occurred while the "interval" setting was involved. Attached gwibber-settings.xml has no "interval" parameter, FWIW.

Traceback:
 Traceback (most recent call last):
   File "/usr/bin/gwibber-service", line 80, in <module>
     dispatcher = dispatcher.Dispatcher(loop)
   File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 276, in __init__
     self.refresh()
   File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 602, in refresh
     self.refresh_timer_id = gobject.timeout_add_seconds(int(60 * SETTINGS["interval"]), self.refresh)
   File "/usr/lib/python2.6/dist-packages/gwibber/microblog/config.py", line 78, in __getitem__
     value = Wrapper.__getitem__(self, key)
   File "/usr/lib/python2.6/dist-packages/gwibber/microblog/config.py", line 47, in __getitem__
     value = GCONF.get("%s/%s" % (self.path, key))
 GError: Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Error connecting: Connection refused)

Gary M (garym) wrote :

Strange... got the same error logging into a GNOME desktop this time. Did UNE eat my gconf or my dbus? Will I ever be able to use my python to gwibber again? Who invents these names? :)

Omer Akram (om26er) wrote :

I believe this issue to be not happening in gwibber 2.32.2 could anyone confirm that? and also the last duplicate was in 2.31.94

Changed in gwibber (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Gary M (garym) wrote :

I have a copy of a crash file with this error showing gwibber-service 2.32.2-0ubuntu1 from November.

Changed in gwibber (Ubuntu):
status: Incomplete → New
Gary M (garym) on 2011-02-14
tags: added: natty
Changed in gwibber (Ubuntu):
status: New → Confirmed
Ant Dickens (antonydickens) wrote :

Also occurs with Gwibber 3.0.0

Marco Diaz (zethabyte) wrote :

I execute the command gconftool-2 --dump /apps/gwibber > gwibber-settings but the result was :

Falló al listar los registros en «/apps/gwibber»: Falló al contactar con el servidor de configuraciones; la causa más común es un demonio de sesión D-Bus mal configurado o faltante. Para obtener más información consulte http://projects.gnome.org/gconf/. (Detalles: 1: Falló al hacer ping al servidor: IDL:omg.org/CORBA/COMM_FAILURE:1.0)

I continue with the problem .

Marco Diaz (zethabyte) wrote :

if execute gwibber-accounts and add an account the error is :

Traceback (most recent call last):
  File "/usr/share/gwibber/plugins/twitter/gtk/twitter/__init__.py", line 71, in on_twitter_auth_clicked
    tokendata = urllib2.urlopen(request.http_url, request.to_postdata()).read()
  File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.7/urllib2.py", line 391, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 409, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 1193, in https_open
    return self.do_open(httplib.HTTPSConnection, req)
  File "/usr/lib/python2.7/urllib2.py", line 1160, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error [Errno 113] No existe ninguna ruta hasta el `host'>

Lisa Simpson (lisa-p) wrote :

I get this bug in Ocelot from Evolution :/

Alan Stevens (seeker9969) wrote :

I didn't actually know it was a bug I just got the error and didn't
understand it and look it up and now I do LOL
I am glad that i installed the bug reporting app
thanks
Al

-----Original Message-----
From: Lisa Simpson <email address hidden>
Reply-to: Bug 619654 <email address hidden>
To: <email address hidden>
Subject: [Bug 619654] Re: gwibber-service crashed with GError in
__getitem__()
Date: Wed, 26 Oct 2011 19:11:31 -0000

I get this bug in Ocelot from Evolution :/

agnul (sucrabu) wrote :

I don't run gwibber and I get this error. I have evolution running most of the time, so I think yes, It could come from Evolution too.

For what is worth I get this dialog box every time I install updates.

Lisa Simpson (lisa-p) wrote :

As far as I know I don't use gwibber. I have a a clean install of Oneric 64 bit. And I get it a LOT when I run updates now too. It seems to be getting worse, not better, but then again my Evolution has other problems. For example, I cannot add a 2nd or any subsequent email addresses because the account assistant crashes. POOF. Gone... Nothing.

ggerri (ggerri) wrote :

I only get this sometimes, when I start evolution. Evolution runs ok after confirming the error notification. My settings are, that mailboxes are automatically checked when evolution starts. I dont use gwibber.

Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* now Is this reproducible?
if so than which version are you using ?

Changed in gwibber (Ubuntu):
status: Confirmed → Incomplete
Changed in gwibber:
importance: Undecided → Medium
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Gwibber because there has been no activity for 60 days.]

Changed in gwibber:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for gwibber (Ubuntu) because there has been no activity for 60 days.]

Changed in gwibber (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers